2

I use my recently bought 1T Seagate Backup Plus Slim external hard disk ID 0bc2:ab24 Seagate RSS LLC (NTFS filesystem) as a backup tool. I want to run the Smartmontools software on this disk, but when I tried to enable it using

smartctl -s on -d scsi /dev/sdb (as a root)

I got the following response:

smartctl 6.6 2016-05-31 r4324 [i686-linux-4.15.0-23-generic] (local b$
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontoo$

=== START OF ENABLE/DISABLE COMMANDS SECTION ===
Informational Exceptions (SMART) disabled
Temperature warning disabled

Indeed when I try to run for example

smartctl -all -d scsi /dev/sdb

the output is:

smartctl 6.6 2016-05-31 r4324 [i686-linux-4.15.0-23-generic] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor:               Seagate
Product:              BUP Slim WH
Revision:             0304
Compliance:           SPC-4
User Capacity:        1.000.204.885.504 bytes [1,00 TB]
Logical block size:   512 bytes
Logical Unit id:      0x5000000000000001
Serial number:        NA9DTQ90
Device type:          disk
Local Time is:        Wed Jun 20 20:25:13 2018 CEST
SMART support is:     Available - device has SMART capability.
SMART support is:     Disabled
Temperature Warning:  Disabled or Not Supported

=== START OF READ SMART DATA SECTION ===
SMART Health Status: OK
Current Drive Temperature:     0 C
Drive Trip Temperature:        0 C

Error Counter logging not supported

Device does not support Self Test logging

which confirms that the SMART support is still disabled, but that is available. Does anyone have an idea if and (if so) how to enable it?

FYI: The drive is connected to an old 32-bit laptop that runs Lubuntu 18.04.

2

Have you checked this question on askubuntu? https://askubuntu.com/questions/207573/how-to-enable-smart If this fails, it could be that your USB enclosure doesn't support SMART, I experienced this with one enclosure of mine. In that case you would need to connect the drive directly via SATA or use a different enclosure to retrieve SMART data from the device.

  • Thank you for your answer. I tried to see in my BIOS whether SMART was enabled, but my computer hanged when I wanted to look at the external HD settings. However I have used SMART support before on this machine. When I ran hdparm I got this output: Enabled Supported: * SMART feature set, ..., so that looks okay, but seems contradictory to the the fact that SMART support still is not enabled. Should I now attempt to specify the BUS (since i don't have problems with my disk, I don't want to open the enclosure)? – ksyrium Jun 21 '18 at 14:10
  • Can you elaborate further on what you mean by "specifying the BUS"? It would be interesting to see the output of "smartctl --scan", particularly what kind of device your drive seems to be. The manual suggests that sometimes it could be useful for external enclosures to specify the type manually by "-d sat" or a different type, see "man smartmontools". Also, you could use smartmontools with "-x" instead of "-a" to get possibly even more information for debugging. – Lollen Jumplan Jun 21 '18 at 14:36
  • On the page askubuntu.com/questions/207573/how-to-enable-smart it is hinted at that details of the BUS connection could help establishing SMART support. The output of smartctl --scan | grep sdb is /dev/sdb -d scsi # /dev/sdb, SCSI device. I just ran smartctl with only -x as an argument (so without -d scsi) and it showed that SMART now is enabled! I don't know what triggered it (maybe a software upgrade?)... B.t.w. It also works fine with -a. – ksyrium Jun 21 '18 at 15:03
  • Nice to see your problem is resolved now. Even though the cause of your problem seems to remain unknown. Maybe it will become clear at a later time. – Lollen Jumplan Jun 21 '18 at 15:40
  • I just found out that it seems to work when smartctl --scan indicates that the HDD is an SCSI device. For some reason it sometimes seems to erroneously display another device, but there's no problem after a reboot without unmounting the drive. – ksyrium Jun 22 '18 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.