0

I tried running an update on my CentOS box and ran into a problem. The last time that I ran an update was in 2018-01 and then yesterday, 2018-06-19.

# yum update
...
--> Finished Dependency Resolution
Error: Package: 1:NetworkManager-1.10.2-14.el7_5.x86_64 (updates)
           Requires: glib2 >= 2.54.2
           Installed: glib2-2.50.3-3.el7.x86_64 (@base)
               glib2 = 2.50.3-3.el7
Error: Package: 1:NetworkManager-glib-1.10.2-14.el7_5.x86_64 (updates)
           Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: python2-ipalib-4.5.4-10.el7.centos.1.noarch (updates)
           Requires: python-netaddr >= 0.7.5-9
           Installed: python-netaddr-0.7.5-7.el7.noarch (@anaconda)
               python-netaddr = 0.7.5-7.el7
Error: Package: gtk3-3.22.26-4.el7_5.x86_64 (updates)
           Requires: libwayland-client(x86-64) >= 1.9.91
           Installing: libwayland-client-1.5.0-4.el7.nux.x86_64 (nux-dextop)
               libwayland-client(x86-64) = 1.5.0-4.el7.nux
Error: Package: libvirt-daemon-3.9.0-14.el7_5.5.x86_64 (updates)
           Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: selinux-policy-targeted-3.13.1-192.el7_5.3.noarch (updates)
           Requires: policycoreutils >= 2.5-18
           Installed: policycoreutils-2.5-17.1.el7.x86_64 (@base)
               policycoreutils = 2.5-17.1.el7
Error: Package: xorgxrdp-0.2.6-2.el7.x86_64 (epel)
           Requires: xorg-x11-server-Xorg(x86-64) = 1.19.5
           Installed: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (@base)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7
Error: Package: libvirt-daemon-driver-nwfilter-3.9.0-14.el7_5.5.x86_64 (updates)
           Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: gtk3-3.22.26-4.el7_5.x86_64 (updates)
           Requires: libwayland-cursor(x86-64) >= 1.9.91
           Installing: libwayland-cursor-1.5.0-4.el7.nux.x86_64 (nux-dextop)
               libwayland-cursor(x86-64) = 1.5.0-4.el7.nux
Error: Package: libvirt-daemon-driver-network-3.9.0-14.el7_5.5.x86_64 (updates)
           Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: gtk3-3.22.26-4.el7_5.x86_64 (updates)
           Requires: libwayland-egl.so.1()(64bit)
Error: Package: openscap-1.2.16-8.el7_5.x86_64 (updates)
           Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: selinux-policy-3.13.1-192.el7_5.3.noarch (updates)
           Requires: policycoreutils >= 2.5-18
           Installed: policycoreutils-2.5-17.1.el7.x86_64 (@base)
               policycoreutils = 2.5-17.1.el7
Error: Package: gtk3-3.22.26-4.el7_5.x86_64 (updates)
           Requires: libwayland-cursor(x86-64) >= 1.9.91
           Available: libwayland-cursor-1.5.0-4.el7.nux.x86_64 (nux-dextop)
               libwayland-cursor(x86-64) = 1.5.0-4.el7.nux
Error: Package: libvirt-libs-3.9.0-14.el7_5.5.x86_64 (updates)
           Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)
Error: Package: gtk3-3.22.26-4.el7_5.x86_64 (updates)
           Requires: libwayland-client(x86-64) >= 1.9.91
           Available: libwayland-client-1.5.0-4.el7.nux.x86_64 (nux-dextop)
               libwayland-client(x86-64) = 1.5.0-4.el7.nux
Error: Package: certmonger-0.78.4-3.el7_5.1.x86_64 (updates)
           Requires: libdbus-1.so.3(LIBDBUS_1_3)(64bit)

If I update glib2 manually, the first error, I get:

[root@datamover102 .hts]# yum install glib2.x86_64
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirrors.oit.uci.edu
 * epel: mirrors.develooper.com
 * extras: mirror.sfo12.us.leaseweb.net
 * nux-dextop: mirror.li.nux.ro
 * updates: repos.lax.quadranet.com
Package glib2-2.50.3-3.el7.x86_64 already installed and latest version
Nothing to do

Yum feels that glib2 is the latest version, while at the exact same time saying that 2.54 is the minimum needed. I believe that 2.56 is the latest version, based on a quick Google search.

I tried yum remove glib2, but that did not go anywhere. I also tried package-clean --dupes, a recommended solution on an article that I read. The output from that was nothing.

There are the other errors too.

Here is a screenshot of the Software Update GUI, a nicer view.

CentOS 7 Software Update showing yum update issues

UPDATE 1

The first suggested answer did not work, here is the output.

[root@datamover102 .hts]# yum install glib2-2.54.2.x86_64
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirrors.oit.uci.edu
 * epel: mirrors.develooper.com
 * extras: mirror.sfo12.us.leaseweb.net
 * nux-dextop: mirror.li.nux.ro
 * updates: repos.lax.quadranet.com
No package glib2-2.54.2.x86_64 available.
Error: Nothing to do
[root@datamover102 .hts]# 

UPDATE 2

I have several CentOS 7 machines, two of them, which needed updating and have not been updated since January 2018. The first one, Machine 101, updated flawlessly, no issues, while the second Machine 102, gave the problems. I just decided to do a listing and that proved interesting, notice the different repos used.

`BAD`
[root@datamover102 yum.repos.d]# yum list glib2
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirrors.oit.uci.edu
 * epel: mirrors.develooper.com
 * extras: mirror.sfo12.us.leaseweb.net
 * nux-dextop: mirror.li.nux.ro
 * updates: repos.lax.quadranet.com
Installed Packages
glib2.x86_64                                   2.50.3-3.el7                                    @base
Available Packages
glib2.i686                                     2.50.3-3.el7                                    base 

GOOD
[root@datamover101 yum.repos.d]# yum list glib2
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos-distro.cavecreek.net
 * epel: mirrors.develooper.com
 * extras: mirror.sfo12.us.leaseweb.net
 * nux-dextop: mirror.li.nux.ro
 * updates: centos.mirror.ndchost.com
Installed Packages
glib2.x86_64                                   2.54.2-2.el7                                    @base
Available Packages
glib2.i686                                     2.54.2-2.el7                                    base 
[root@datamover101 yum.repos.d]# 

Basically, the bad machine uses base: mirrors.oit.uci.edu as a base, while the good machine uses centos-distro.cavecreek.net as the base.

The answer is in having the bad machine not use mirrors.oit.uci.edu as the base. Here is a listing, which matches on both machines.

[root@datamover102 yum.repos.d]# ls -la
total 56
drwxr-xr-x.   2 root root  252 Jun 20 16:38 .
drwxr-xr-x. 144 root root 8192 Jun 20 15:33 ..
-rw-r--r--    1 root root 1664 May 17 06:53 CentOS-Base.repo
-rw-r--r--.   1 root root 1309 Sep 27  2017 CentOS-CR.repo
-rw-r--r--    1 root root  649 May 17 06:53 CentOS-Debuginfo.repo
-rw-r--r--    1 root root  314 May 17 06:53 CentOS-fasttrack.repo
-rw-r--r--    1 root root  630 May 17 06:53 CentOS-Media.repo
-rw-r--r--    1 root root 1331 May 17 06:53 CentOS-Sources.repo
-rw-r--r--    1 root root 4768 May 17 06:53 CentOS-Vault.repo
-rw-r--r--    1 root root  951 Oct  2  2017 epel.repo
-rw-r--r--    1 root root 1050 Oct  2  2017 epel-testing.repo
-rw-r--r--.   1 root root  477 Jul 31  2014 nux-dextop.repo
  • Is the repository from which glib2 was installed still enabled on your host? – DopeGhoti Jun 20 '18 at 15:43
  • glib2-2.54.2-2 is definitely available for CentOS 7. Have you tried yum clean all first and then installing the package? – Nasir Riley Jun 20 '18 at 15:48
1

I did some more research and turned up this page. The relevant part of that article is this:

8.1. Disabling or Removing Package Sources
Set enable=0 in a definition file to prevent yum from using that repository. The yum utility ignores any definition file with this setting.

To completely remove access to a repository:

Delete the relevant file from /etc/yum.repos.d/.

Delete the cache directory from /var/cache/yum/.

I did the first step, by setting enabled = 0 in CentOS-CR.repo, as per my download of the /etc/yum.repos.d directory from both 101 and 102 to my Windows box. Araxis Merge turned up that one difference.

Restarting the computer did not do the trick after that point, but deleting the x8x_64 directory from /var/cache/yum did do the trick. I then did a:

# yum update glib2.x86_64 (a success to 2.54)

followed by a:

# yum update
  • just want to confirm, running yum update glib2 fixed the error for me. – printfmyname Jan 3 at 3:15
0

Have you tried forcing it to install the specific version of glib2?

It will probably not work but will give you insight about what is going wrong.

Try yum install glib2-2.54.2.x86_64 and get back to me with the output.

Might want to try yum remove glib2 before installing the newer version.

  • 1
    I already tried yum remove glib2. I thought that I mentioned that. That threw many, many dependency errors. The force install did not work, see output above. CentOS does not know that there is a newer version. Besides, it should go to 2.56.1 not 2.54.2. – Sarah Weinberger Jun 20 '18 at 15:41
  • Well if the version you are after is 2.56.1 you should try yum install glib2-2.56.2.x86_64 – TaiTair Jun 20 '18 at 15:56
  • See update 2 in my question. The problem is the base. I already tried what you said, no update found. The good machine, 101, uses centos-distro.cavecreek.net as the base, while the bad machine uses mirrors.oit.uci.edu as the base. That site is not a repos, as I list then in my updated question. What site to use is somewhere else, something else. ;-) (to all those that watch Arrow). – Sarah Weinberger Jun 20 '18 at 16:05
  • 1
    Ok then this should be easy to solve. Change your base mirrors for the affected repos. You should be able to get the repos from the CentOS website. In Theory, copying the repos from 101 to 102 should also work (I do say in theory because anything can go wrong) – TaiTair Jun 20 '18 at 16:13
  • I have been trying to find a way to do just that since I posted my last comment to you. Sadly, various searches along the lines CentOS 7 yum baseurl update repos does not cut the mustard. I am trying to find out how to tell yum to use a different base your. I /etc/yum.repos.d directory is identical on both machines, so that is out. I even compared the files. Missing is a how to step-by-step. – Sarah Weinberger Jun 20 '18 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.