1

I have a dual boot Debian 9 (controls the boot process) and W10 being the other possible boot.

After performing a simple overclock setup over the BIOS (MSI X399 motherboard), the computer now sends me directly into grub rescue console when I start the computer, where it reads:

"error: file'/boot/grub/i386-pc/normal.mod' not found."

I know how to perform the "set prefix=..." and "insmod" tasks to setup grub on boot, but my specific problem is not there. All my *.mod files, including "normal.mod" are in a differently-named folder: "x86_64-efi", not the "i386-pc" that the grub insists on fetching. Even as I perform a "set prefix=..." to the right folder, grub will still try to read "normal.mod" in the "i386-pc" folder which simply does not exist.

What are the possible fixes to this without disassambling the SSD from the computer? Grub rescue commands are extremely limited unfortunately, so I cannot copy/move contents for example. Thank you very much to anyone having leads on this.

grub rescue attempts screenshot

  • The grub-pcstuff belongs to the BIOS (CSM legacy) bootloader. I would guess that the simple overclock setup over the BIOS made the computer want these files (probably in order to boot in BIOS mode), 1. Try to boot in UEFI mode; 2. If that is not possible, boot from another drive (for example a live USB drive) and install the BIOS bootloader (and make it point to the installed system). – sudodus Jun 20 '18 at 13:56
  • You are right. Booting in UEFI mode got me into the boot menu where I choose to launch linux OS. Thank you very much for your help. – Julio Jun 20 '18 at 19:56
0

I had the exact same problem, but while reinstalling ubuntu.

This guy over here got me the first half of the solution RIGHT HERE Give him a view.

Since I have only tried using Ubuntu images, try to abstract these information:

  1. Try Ubuntu on the respective image.
  2. Open terminal
  3. Add the repositories and install the boot-repair given in the video.
  4. Try again

This made me at least find the ubuntu installed. Since I also had windows installed, I had to update my grub

  1. sudo update-grub
  2. Reinstall

This worked for me and I hope it works for you =)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.