1

I have a ThinkPad Yoga 370 with an active AES stylus. I run the latest Arch Linux-based Manjaro 4.14.48-2-MANJARO. To get the pen to work in e.g. xournal I installed libinput 1.11.0-1 and xf86-input-wacom 0.36.1-1 and the pen works now.

However my problem comes undeterministically after some time using it. When I write, at some point driver issues arise, where when I move the pen close to the display, an event is triggered that moves the mouse pointer according to where the pen is, without the pen touching the display. This is normal behaviour. The problem is that on the instance this pen is in range event is fired, for some reason a pen touched the display event is fired instead, so that a click is issued. When I hover over a button that button is pressed, when I hover over my document in xournal a dot is drawn.

Repeatedly moving the pen to and from the display makes the problem go away for a while, but it always returns.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.