3

When I log into my desktop session, Plasma shell is unresponsive and CPU utilization is 100%. I have tracked this down to an issue with KDE Wallet and an attempt to make a WiFi connection. Unfortunately, I cannot resolve the issue via the desktop session because it is mostly unresponsive.

I am seeking a command line solution. I can log in via SSH or I can log into the console without SDDM & Plasma.

I saw a similar solution here: https://unix.stackexchange.com/a/36444/15010

cd $(kde4-config --localprefix)share/apps/kwallet mv kdewallet.kwl
kdewallet.kwl.bak

However, I do not have a directory at ~/.kde4/share/apps/kwallet

The closest I find is ~/.kde/share/apps/kwallet where I have I see only this one file: kdewallet.salt

find . -iname "wallet"

./.config/kwalletrc
./.config/kwalletmanager5rc
./.kde/share/apps/kwallet
./.kde/share/apps/kwallet/kdewallet.salt
./.kde/share/config/kwalletrc
./.kde4/share/config/kwalletrc
./.local/share/kwalletd
./.local/share/kwalletd/kdewallet.salt
1
  • Going out on a limb, but would uninstalling the wallet w/o removing dependencies help? – ajeh Jun 19 '18 at 21:47
2

I think you have a couple of options:

pkill kwallet

to kill the current wallet processes. If your desktop is still unresponsive, change Enabled=false in ~/.config/kwalletrc and log out and back in.

On a side note, you can open the wallet configuration with kcmshell5 kwalletconfig5, but it crashes without a gui.

1
  • I think this is probably the right answer. Unfortunately, it did not work for me. After changing ~/.config/kwalletrc, kwallet continues to pop up and cause problems when I log in. – MountainX Jun 20 '18 at 5:44
1

For KDE4:

kwriteconfig --file kwalletrc --group 'Wallet' --key 'Enabled' 'false'
kwriteconfig --file kwalletrc --group 'Wallet' --key 'First Use' 'false'

For KDE5:

kwriteconfig5 --file kwalletrc --group 'Wallet' --key 'Enabled' 'false'
kwriteconfig5 --file kwalletrc --group 'Wallet' --key 'First Use' 'false'

Source:

# Kwallet is annoying, and also makes connecting
# to wireless networks take multiple attempts -- no thanks.

https://github.com/ryanpcmcquen/linuxTweaks/blob/e60f2421a3b98c7741a0b27cfe176db10e130a1f/.kdeSetup.sh#L18

Related:

Disable KWallet password request in Arch Plasma 5

https://askubuntu.com/questions/47216/how-to-disable-kde-wallet

https://stackoverflow.com/questions/29594260/how-to-disable-kwallet-in-kde-plasma-5

https://superuser.com/questions/994551/disable-kwallet-popups-from-chrome

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.