1

I've just installed a fresh new Debian 9 LXDE into an ACER AMD Notebook and everything seems to be working fine. However, during the boot, there is an annoying Strong Backlight Flash (seems like a photo flash). The sequence of events are basically as following:

  • Boot starts at maximum backlight brightness
  • Debian OS is selected at GRUB menu
  • Some messages appear in low resolution at the command line
  • Strong Backlight Flash
  • Command line is now in high resolution
  • Backlight Brightness is set to user pre-defined level
  • LXDE login screen

Considering that during the Windows era of this notebook such flash never happened, I'm pretty sure there is a way via software to avoid that.

Question
How to avoid this Strong Backlight Flash?


Debug

root@debian:~# dmesg | grep -i "error\|firmware\|backlight"
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-6-amd64 root=UUID=740fe980-f018-4c49-b139-613d41d30fb9 ro quiet acpi_backlight=video
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-6-amd64 root=UUID=740fe980-f018-4c49-b139-613d41d30fb9 ro quiet acpi_backlight=video
[    0.294171] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.311772] acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
[    1.057843] pci 0000:01:00.0: [Firmware Bug]: disabling VPD access (can't determine size of non-standard VPD format)
[    7.131791] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   12.551069] radeon 0000:00:01.0: firmware: direct-loading firmware radeon/PALM_pfp.bin
[   12.685950] radeon 0000:00:01.0: firmware: direct-loading firmware radeon/PALM_me.bin
[   12.705633] radeon 0000:00:01.0: firmware: direct-loading firmware radeon/SUMO_rlc.bin
[   12.762705] radeon 0000:00:01.0: firmware: direct-loading firmware radeon/SUMO_uvd.bin
[   13.481390] [drm] radeon atom DIG backlight initialized  

Hardware Specifications
Notebook Aspire E1-421-0622 | product details

  • AMD 2 Core™ Processor E1-1200 (1.4 GHz) 1MB Cache 64-bit Processing
  • AMD Radeon HD 7310 Graphics Controller
  • 2Gb DDR3 SDRAM Memory
  • 256MB shared video memory

 

Debian Strech
debian-9.4.0-amd64-netinst.iso

  • Software selection
    (  ) Debian desktop environment
    (  ) ... GNOME
    (  ) ... Xfce
    (  ) ... KDE
    (  ) ... Cinnamon
    (  ) ... MATE
    (X) ... LXDE
    (  ) web server
    (X) print server
    (  ) SSH server
    (X) standard system utilities
  • Minor adjustments:

    • Non-free package firmware-amd-graphics installed (full discussion)
    • /etc/default/grub file updated (full discussion):

      GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_backlight=video"  
      
1

I felt unhappy about the same problem on my laptop maybe longer then this question stays open.

There is a solution: Disable backlight control in radeon driver by adding radeon.backlight=0 to kernel boot parameters.

But. The problem here is that you might need another module to control the backlight. This means that instead of acpi_backlight=video you first should test your system with acpi_backlight=vendor or acpi_backlight=native.

More about backlight on Arch Wiki and about ACPI video extensions in kernel docs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.