Can anyone tell me how to determine if the barriers option is turned on for my XFS filesystem? The XFS docs say that it's on by default since kernel 2.6 but I want to know for sure that it's on.

I'm running Fedora 23.

uname -a
Linux localhost.localdomain 4.4.8-300.fc23.x86_64 #1 SMP Wed Apr 20 16:59:27 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

[sri@localhost ~]$ xfs_info /
meta-data=/dev/mapper/fedora-root isize=512    agcount=4, agsize=2424576 blks
         =                       sectsz=512   attr=2, projid32bit=1
         =                       crc=1        finobt=1 spinodes=0
data     =                       bsize=4096   blocks=9698304, imaxpct=25
         =                       sunit=0      swidth=0 blks
naming   =version 2              bsize=4096   ascii-ci=0 ftype=1
log      =internal               bsize=4096   blocks=4735, version=2
         =                       sectsz=512   sunit=0 blks, lazy-count=1
realtime =none                   extsz=4096   blocks=0, rtextents=0

Is the fact that there is not barrier=0 option in the mount output confirmation?

[sri@localhost ~]$ mount | grep xfs
/dev/mapper/fedora-root on / type xfs (rw,relatime,attr2,inode64,noquota)
/dev/mapper/fedora-home on /home type xfs (rw,relatime,attr2,inode64,noquota)

1 Answer 1


XFS enables write barriers by default since kernel version 2.6.17, but they can be disabled using explicit nobarrier. As you can see in your mount output, nobarrier option is not used.

According to XFS FAQ, if write barriers are disabled without the explicit mount option, a log entry is generated. You can check the kernel logs on running system with dmesg.

Kernels after version 4.10 will always perform integrity operations and barrier/nobarrier mount option is ignored (documented in man 5 xfs and commit message)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .