0

Having read this page, I decided to give AFT a try, so I installed it by sudo pacman -S android-file-transfer, connected the device (OnePlus 3T) to the computer through USB, set it to "Transfer files mode", and then opened AFT. So far so good, I see all folders inside my device, I can select files and dowload them. I haven't tried uploading, but I think everythig's ok.

Except that I'd prefer to browse the device in the terminal, so that I can make use of regexp to move stuff from/to the device.

I've found the following

$ ll /dev/disk/by-id
...
usb-OnePlus_Device_Driver_5abf662b-0:0 -> ../../sr0
...

but when I try

$ mkdir mount_here
$ sudo mount /dev/sr0 mount_here

all I see is this

$ ll mount_here
total 18466
dr-xr-xr-x 1 root   root       2048 Sep  7  2016  ./
drwx------ 1 enrico enrico      912 Jun 17 15:34  ../
-r-xr-xr-x 1 root   root    6538856 Mar  3  2015 'AndroidFileTransfer(OSX).dmg'*
-r-xr-xr-x 1 root   root   12320875 Sep  5  2016  OnePlus_USB_Drivers_Setup.exe*
-r-xr-xr-x 1 root   root      45056 Jun  3  2015  OnePlus_setup.exe*
-r-xr-xr-x 1 root   root        794 Jun 30  2015  adb_config_Linux_OSX.sh*
-r-xr-xr-x 1 root   root         97 Jun  3  2015  autorun.inf*
  • Run mount before and after attaching the device to see what changes. If nothing changes, you can always use aft-mtp-mount to mount it anywhere – Fox Jun 17 '18 at 14:21
  • mount gives the same result before and after attaching the device; the same also after setting transfer files from Android. Then aft-mtp-mount mount_here gives Device::Find failed:Device is already used by another process if I set transfer files on the device, connect failed: no MTP device found if I had not. – Enrico Maria De Angelis Jun 17 '18 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.