1

I am trying to install CentOS in VirtualBox via kickstart files. I have downloaded the CentOS Minimal installation (1708) and created a virtual machine with it.

I am using the anaconda-ks.cfg file as the default kickstart file for it.

With the base CentOS iso, I have extracted it via 7z, placed my kickstart file in DirName as DirName/anaconda-ks.cfg. I then made an iso for it.

7z x CentOS-7-x86_64-Minimal-1708.iso -oDirName
sudo genisoimage -joliet-long -o NameForISO.iso -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -J -R -v -T -V 'CentOS 7 x86_64' DirName

Note: In isolinux.cfg I added the lines (as in http://ideanist.com/2017/03/09/unattended-kickstart-installation-centos-7/):

label is
  menu label ^Kickstart
  menu default
  kernel vmlinuz
  append initrd=initrd.img inst.stage2=hd:LABEL=CentOS\x207\x20x86_64 inst.ks=cdrom:/anaconda-ks.cfg quiet

Errors: Upon attaching the iso to my virtual machine, and selecting the kickstart option, I see 3: [!] Installation source (Error setting up software source). if I do not have any network information included in my anaconda-ks.cfg file. If I include the lines:

network  --bootproto=static --device=eth0 --gateway=1.1.1.1 --ip=2.2.2.2 --netmask=255.255.255.0 --ipv6=auto --activate
network  --bootproto=static --device=eth1 --gateway=3.3.3.3 --ip=4.4.4.4 --netmask=255.255.255.128 --ipv6=auto --activate

I get Starting automated install....., and the . trail on forever, never installing using my kickstart file.

How do I get rid of these errors? Am I not specifying something properly?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.