-1

My work laptop is a Dell Precision 7510 currently running Fedora 26. At boot, it usually (ie, the majority of attempts) gets stuck with a black screen before the point at which it would show a Fedora logo. I have to hard power-cycle it and try again; after anything from one to ten attempts it finally "catches" like a balky outboard motor and starts running.

A while back a colleague suggested adding something to the grub config; his suggestion didn't work at all but did help narrow down the point at which it's freezing. If I edit the config ('e' at the prompt) to add a nonsense command and then attempt to start (ctrl-x), I get a message saying the command is unknown and to press any key, and the freeze (unless this is the lucky time that it decides to start) happens immediately thereafter with nothing more displayed. I had been concerned that the problem was in hardware, but the fact that I can do grub stuff every time even if the boot then fails, implies that it's a Linux problem.

I don't know enough about how Fedora boots to know where to start looking. Any suggestions would be very welcome.

FWIW this used to happen back when I was running Fedora 24 too.

1

Have you tried editing GRUB like you said (e) and removing the quiet option? That helps to show more info on boot.

  • I had not - thanks. Just tried it now, and the result is still a blank screen - no additional information displayed :-( – Pete Verdon Jun 15 '18 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.