0

I've a kernel-panic problem (I think) trying to use the liveCD of gNewSense 4.0 for i386. The error is the following:

[8.598401] xhci_queue_intr_tx: 78 callbacks suppressed.
.
.
.

It's showing the same error with different codes (70 for example) as long as my laptop is turned on.

I'll give you some information about my hardware:

uname -m
x86_64

sudo lshw -short
[sudo] password for lucasdavid: 
H/W path       Device      Class          Description
=====================================================
                           system         Inspiron 14-3467 (078A)
/0                         bus            0PW5P4
/0/0                       memory         64KiB BIOS
/0/3d                      memory         6GiB System Memory
/0/3d/0                    memory         4GiB SODIMM Synchronous 2400 MHz (0,4 ns)
/0/3d/1                    memory         2GiB SODIMM Synchronous 2400 MHz (0,4 ns)
/0/41                      memory         128KiB L1 cache
/0/42                      memory         512KiB L2 cache
/0/43                      memory         3MiB L3 cache
/0/44                      processor      Intel(R) Core(TM) i3-6006U CPU @ 2.00GHz
/0/100                     bridge         Sky Lake Host Bridge/DRAM Registers
/0/100/2                   display        Sky Lake Integrated Graphics
/0/100/4                   generic        Intel Corporation
/0/100/14                  bus            Intel Corporation
/0/100/14/0    usb2        bus            xHCI Host Controller
/0/100/14/1    usb1        bus            xHCI Host Controller
/0/100/14/1/1              input          USB Optical Mouse
/0/100/14/1/2              multimedia     USB PnP Sound Device
/0/100/14/1/5              multimedia     Integrated_Webcam_HD
/0/100/14/1/6              generic        USB2.0-CRW
/0/100/14/1/8              communication  Bluetooth wireless interface
/0/100/14.2                generic        Intel Corporation
/0/100/15                  generic        Intel Corporation
/0/100/15.1                generic        Intel Corporation
/0/100/16                  communication  Intel Corporation
/0/100/17                  storage        Intel Corporation
/0/100/1c                  bridge         Intel Corporation
/0/100/1c/0    wlp1s0      network        QCA9565 / AR9565 Wireless Network Adapter
/0/100/1c.5                bridge         Intel Corporation
/0/100/1c.5/0  enp2s0      network        RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
/0/100/1f                  bridge         Intel Corporation
/0/100/1f.2                memory         Memory controller
/0/100/1f.3                multimedia     Intel Corporation
/0/100/1f.4                bus            Intel Corporation
/0/1           scsi0       storage        
/0/1/0.0.0     /dev/sda    disk           1TB ST1000LM035-1RK1
/0/1/0.0.0/1               volume         599MiB Windows FAT volume
/0/1/0.0.0/2   /dev/sda2   volume         3071MiB Windows FAT volume
/0/1/0.0.0/3   /dev/sda3   volume         516GiB EXT4 volume
/0/1/0.0.0/4   /dev/sda4   volume         11GiB Linux swap volume
/0/1/0.0.0/5   /dev/sda5   volume         399GiB EXT4 volume
/0/2           scsi1       storage        
/0/2/0.0.0     /dev/cdrom  disk           DVD+-RW DU-8A5LH
/1                         power          DELL 78V9D72

I think the problem is with some usb, so more information:

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 009: ID 0cf3:e005 Atheros Communications, Inc. 
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 004: ID 0bda:5769 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller
Bus 001 Device 002: ID 1bcf:0823 Sunplus Innovation Technology Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

That's all!

  • Just out of curiosity: Any reason why are you using i386 instead of amd64? – user34720 Jun 15 '18 at 17:43
  • Also, have you tried do blacklist your Realtek card reader module? SdReaders, usb ports and wifi modules of that brand are a bit problematic on Linux - linuxquestions.org/questions/slackware-14/… – user34720 Jun 15 '18 at 17:50
  • You're right. I've downloaded the wrong version. – Lucas David Ferrero Jun 15 '18 at 18:00
  • Where do I disable them? I'm running Ubuntu in one of my partitions. Do I need to compile the kernel by myself? – Lucas David Ferrero Jun 15 '18 at 22:49
  • No. You can do it at grub. askubuntu.com/questions/110341/how-to-blacklist-kernel-modules . If you are using a LiveCD, they usually have syslinux as bootloader, and using the modprobe.blacklist=name_of_module should be enough – user34720 Jun 16 '18 at 16:20
0

This distribution doesn't have proper drivers for 2 USB and network card that comes with my laptop. I've just installed Trisquel and it works perfectly now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.