3

Since I installed i3 on Arch Linux I noticed a too big font size (in what was the first thing I saw, the i3bar at the bottom), so I changed the font size in the .config/i3/config file (now the line reads font pango:DejaVuSansMono Nerd Font Mono 5.

Soon enough I noticed that the size of the menu bars of the application was too big, so I edited it with Lxappearance (now the default font is DejaVuSansMono Nerd Font Book with size 4) and the GUI of Lxappearance itself looks perfect.

But the rest still does not, as you can see from the screenshot: the font is too big, I'd say huge, in the floating Open window, wherease it is tiny, if not invisible, in the Audacity window on the right; finally it seems normal on the TikZiT window on the left.

In addition (I don't know how to take a picture of this, but I'm sure it wouldn't add anything to this question), if I right-click on the Dropbox icon I see a huge font in the white pop-up menu (the same font I see by hovering with the cursor on that icon); when I do the same with Skype (not in the picture) the font i see is the tiny one on the Arc-dark pop-up menu.

I'm new to this do-all-by-yourself-from-scratch world in which ArchLinux and i3 live. And I'd rather not give up after a week or two.

enter image description here

EDIT 1

Here another picture where B are the fonts looking quite ok (I say quite, since I don't even know where they come from), whereas A are the too-tiny fonts. Which are not set by qt5ct.

enter image description here

EDIT 2

I start thinking that maybe is not a conflict between GTK and Qt: as you can see in the following screenshot, I've set similar but definitely not identical themes with qt5ct (left) and lxappearance (right), but pavucontrol (center), which uses GTK, present that tiny unreadable font.

enter image description here

[![enter image description here][4]][4]

3
  • you may need to set environment variables in X startup files to enforce a default theme on toolkits like GTK or Qt. GTK_THEME may be sufficient.
    – quixotic
    Jun 14, 2018 at 20:23
  • @quixotic, could you please give more details about what to do? I'm reading this page, and this section, but I'm not sure I've understood what to do. Sure, I've some idea about what I could try, but, given I'm so newbie, guess&try is a good chance to break everything down.
    – Enlico
    Jun 15, 2018 at 6:13
  • I've followed this page (which was suggested here too and tried installing qt5ct and putting [ "$XDG_CURRENT_DESKTOP" = "KDE" ] || [ "$XDG_CURRENT_DESKTOP" = "GNOME" ] || export QT_QPA_PLATFORMTHEME="qt5ct" in ~/.xprofile, so now I have another GUI application to set font sizes and stuff, but tiny fonts are still nearly microscopic.
    – Enlico
    Jun 16, 2018 at 20:09

1 Answer 1

2

I solved the problem myself by pure chance, while trying to make steam work. While troubleshooting, this answer led me to realize that nvidia drivers were installed along side xf86-video-nouveau and mesa, so I run sudo pacman -R nvidia and reboot, hoping that steam would then work, but I "happly" found that extremely tiny font everywhere, so I just had to change fonts in i3 config file, .Xdefaults, qutebrowser setting, ... since all I had set at the time I posted this question, was conditioned by the conflicting drivers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .