11

In older versions I used to comment out osd.show(percent) in the functions increaseVolume and decreaseVolume in the file /usr/share/plasma/plasmoids/org.kde.plasma.volume/contents/ui/main.qml (blog source). But that file does not exist anymore in Plasma 5.13. Is there an other way to disable it?

enter image description here

1
  • 1
    Not sure if useful, but I modify the OSD to make it smaller and persist for less time. I patch the files in /usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/osd.
    – Sparhawk
    Dec 18, 2018 at 23:17

2 Answers 2

3

Right-click the volume icon in the tray

enter image description here

and select Configure KMix….

enter image description here

Unselect Show On Screen Display (OSD) then click OK (or Apply).

This is equivalent to editing ~/.config/kmixrc and adding the line:

showOSD=false
11
  • P.S. I have no idea why my fonts, etc., are cropped like that.
    – Sparhawk
    Apr 18, 2019 at 8:34
  • 3
    When I right-click the volume icon I don't have the Configure KMix option. The only option I have is Configure Audio Volume....
    – MatMis
    Apr 22, 2019 at 9:49
  • @MatMis I added a screenshot for when right-click the icon. What version of plasma are you on now? I'm using 5.15.4. I also wonder if your volume icon is not actually kmix, but something else.
    – Sparhawk
    Apr 22, 2019 at 10:13
  • @Sparkhawk I'm also using KDE 5.15.4 (on Antergos).
    – MatMis
    Apr 22, 2019 at 12:33
  • 1
    For me in Plasma 5.21.2 it was Configure Audio Volume... and then Show visual feedback for changes to:. Then uncheck Audio volume and Mute state
    – hrvoj3e
    Mar 12, 2021 at 10:45
1

what you gotta do is right click the speakers tray icon and then click audio volume after that uncheck audio feedback and you're good to go

1
  • 1
    Please add the kde-plasma version for which your trick can apply. (It was not possible on the version the OP was running… 4 years ago…)
    – MC68020
    Aug 13, 2022 at 15:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .