1

I installed the openrazer-2.3.0 and polychromatic-0.3.11.1 and plugged in the new keyboard. During bios the keyboard works but as soon as Linux (CentOS7) boots, none of the keys on the key board do anything (press key, nothing happens). The colours on the keyboard work just fine and I am able to switch theme using polychromatic-controll just fine.

Sadly, the openrazer developers do not support CentOS so I cannot get any help there… ☹

Any idea how I can get this to work?

The module seems to be there:

; sudo modprobe razerkbd                  
; echo $?      
0

But

; uname -a     
Linux serval.tld.co.uk 3.10.0-862.3.2.el7.x86_64 #1 SMP Mon May 21 23:36:36 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
; dmesg | ag -i razer
[    2.103400] usb 2-1.6: Product: Razer BlackWidow Chroma V2
[    2.103401] usb 2-1.6: Manufacturer: Razer
[    2.104150] input: Razer Razer BlackWidow Chroma V2 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/input/input5
[    2.154354] hid-generic 0003:1532:0221.0003: input,hidraw2: USB HID v1.11 Keyboard [Razer Razer BlackWidow Chroma V2] on usb-0000:00:1d.0-1.6/input0
[    2.155163] input: Razer Razer BlackWidow Chroma V2 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.1/input/input6
[    2.206258] hid-generic 0003:1532:0221.0004: input,hidraw3: USB HID v1.11 Keyboard [Razer Razer BlackWidow Chroma V2] on usb-0000:00:1d.0-1.6/input1
[    2.206914] input: Razer Razer BlackWidow Chroma V2 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.2/input/input7
[    2.207010] hid-generic 0003:1532:0221.0005: input,hidraw4: USB HID v1.11 Mouse [Razer Razer BlackWidow Chroma V2] on usb-0000:00:1d.0-1.6/input2
[    3.644772] razerkbd: loading out-of-tree module taints kernel.
[    3.645663] razerkbd: module verification failed: signature and/or required key missing - tainting kernel
[    3.771283] input: Razer Razer BlackWidow Chroma V2 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.0/input/input11
[    3.778643] input: Razer Razer BlackWidow Chroma V2 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.2/input/input12
[    3.810552] razerkbd 0003:1532:0221.0003: input,hidraw2: USB HID v1.11 Keyboard [Razer Razer BlackWidow Chroma V2] on usb-0000:00:1d.0-1.6/input0
[    3.810689] razerkbd 0003:1532:0221.0005: input,hidraw3: USB HID v1.11 Mouse [Razer Razer BlackWidow Chroma V2] on usb-0000:00:1d.0-1.6/input2
[    3.814567] input: Razer Razer BlackWidow Chroma V2 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6:1.1/input/input16
[    3.814733] razerkbd 0003:1532:0221.0004: input,hidraw4: USB HID v1.11 Keyboard [Razer Razer BlackWidow Chroma V2] on usb-0000:00:1d.0-1.6/input1

Also

; sudo journalctl -b | grep -i razer_mount
1150:Jun 14 08:31:05 serval.tld.co.uk razer_mount[695]: Driver razerkbd
1152:Jun 14 08:31:05 serval.tld.co.uk razer_mount[696]: Device_ID 0003:1532:0221.0003
1153:Jun 14 08:31:05 serval.tld.co.uk razer_mount[698]: Driver razerkbd
1154:Jun 14 08:31:05 serval.tld.co.uk razer_mount[697]: Driver razerkbd
1155:Jun 14 08:31:05 serval.tld.co.uk razer_mount[700]: Unbinding 0003:1532:0221.0003 from hid-generic
1156:Jun 14 08:31:05 serval.tld.co.uk razer_mount[702]: Device_ID 0003:1532:0221.0004
1158:Jun 14 08:31:05 serval.tld.co.uk razer_mount[701]: Device_ID 0003:1532:0221.0005
1162:Jun 14 08:31:05 serval.tld.co.uk razer_mount[703]: Unbinding 0003:1532:0221.0004 from hid-generic
1166:Jun 14 08:31:05 serval.tld.co.uk razer_mount[707]: Unbinding 0003:1532:0221.0005 from hid-generic
1201:Jun 14 08:31:05 serval.tld.co.uk razer_mount[769]: Binding 0003:1532:0221.0003 to razerkbd
1207:Jun 14 08:31:05 serval.tld.co.uk razer_mount[787]: Binding 0003:1532:0221.0005 to razerkbd
1248:Jun 14 08:31:05 serval.tld.co.uk razer_mount[794]: Binding 0003:1532:0221.0004 to razerkbd
1254:Jun 14 08:31:05 serval.tld.co.uk razer_mount[818]: Finished binding 0003:1532:0221.0004
1255:Jun 14 08:31:05 serval.tld.co.uk razer_mount[817]: Finished binding 0003:1532:0221.0003
1256:Jun 14 08:31:05 serval.tld.co.uk razer_mount[819]: Finished binding 0003:1532:0221.0005
1257:Jun 14 08:31:05 serval.tld.co.uk razer_mount[822]: Changing group /sys/bus/hid/drivers/razerkbd/0003:1532:0221.0003/
1258:Jun 14 08:31:05 serval.tld.co.uk razer_mount[821]: Changing group /sys/bus/hid/drivers/razerkbd/0003:1532:0221.0005/
1259:Jun 14 08:31:05 serval.tld.co.uk razer_mount[820]: Changing group /sys/bus/hid/drivers/razerkbd/0003:1532:0221.0004/
1260:Jun 14 08:31:05 serval.tld.co.uk razer_mount[826]: Changed group /sys/bus/hid/drivers/razerkbd/0003:1532:0221.0003/
1261:Jun 14 08:31:05 serval.tld.co.uk razer_mount[827]: Changed group /sys/bus/hid/drivers/razerkbd/0003:1532:0221.0004/
1262:Jun 14 08:31:05 serval.tld.co.uk razer_mount[828]: Changed group /sys/bus/hid/drivers/razerkbd/0003:1532:0221.0005/

Update: after some testing, it seems that the driver is working fine. However, something is stopping key strokes to get to the OS! I tested the keyboard with a different CentOS 7 installation without the driver and it worked fine. I tested no driver on my main machine and no luck here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.