0

I recently installed Debian stable and now after boot I get a grub command line instead of the usual menu. When I run configfile (hd0,gpt6)/boot/grub/grub.cfg, I get to the grub menu and see that Debian as well as Widnows are listed there, so grub seems to be installed correctly. I know that there many questions around this already, so here is what I have tried already to solve the issue:

  • Boot into a boot-repair-disk and run recommended repair from there
  • Manually mount the system from a live disk chroot into it and install grub
  • Following this, I ran update-grub and install-grub /dev/sda
  • Also tried grub-mkdevicemap, grub-install /dev/sda, and then update-grub

None of this worked, I still get the grub prompt after booting.

I have a dual boot setup with Windows on another partition. Secure boot is disabled. Before I installed Debian on this partition I had another distro installed on it and the grub menu worked fine.

0

Solved it, I seems like the boot manager was still loading the Ubuntu grub and the Debian grub was not included. I just has to execute bcdedit /set "{bootmgr}" path \EFI\debian\grubx64.efi from Windows PowerShell.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.