0

Per the accepted answer to this closely-related question, I installed Atom editor on my LinuxMint 18.3 Cinnamon machine using LinuxMint's Software Manager (mintinstall 7.8.9).

I want to install packages and open files from the command line, but BASH raises "command not found" or "program not installed" errors when I try to "apm install foo" or "atom baz.py". I am aware that it's possible to install packages through atom's GUI (ctrl+shift+p ; "Install Packages and Themes"), but I want to get the shell commands up and running.

Research (this, and this) told me that the Linux version of Atom doesn't have a baked-in tool to "Install Shell Commands", so I figured I should update my $PATH.

Unfortunately, even after I figured out where Software Manager put the executables I needed, their behavior was inconsistent. "atom" failed to run, citing a bad path or nonexistent file error on line 5. "atom-real" would run, but didn't reflect the same state I got when I choose atom from the menu or panel. With such poor results, I chose not to update #PATH.

Something's broken, and I'm not sure where to go from here. My apologies for failing to track all error messages - hopefully my approximations are close enough.

0

With assistance from a co-worker, I found the source of the problem (user error), and fixed it (by deleting and properly reinstalling Atom).

TLDR: Make sure you follow all of Atom's configuration instructions prior to installing Atom through Software Manager. If you didn't, you may have to uninstall/configure/reinstall.

What I did wrong: I misunderstood the Atom install instructions and failed to properly configure Software Manager before installing, under the false assumption that installing through Software Manager was a one-stop shop.

How I fixed it: I deleted Atom and re-installed after following the handy Debian/Ubuntu configuration walkthrough on the Atom install instructions page. In retrospect, this seems painfully obvious, but coming from Windows I'm used to comprehensive installers and auto-updates, and didn't understand the purpose of the configuration process.

On re-installing after configuring properly, the shell commands worked properly out of the box.

Why it didn't work the first time: I'll avoid copy-pasting code here (please refer to the install page linked above), but will summarize in case the concepts are useful to someone. The configuration instructions Atom provides tell your system where to look for the official (and up-to-date) repository of Atom files, so that when you install Atom it is configured correctly.

I'm not sure why the initial Atom install didn't work properly. Probably, the repo Software Manager was pointed at out of the box was incomplete, outdated, or otherwise buggy.

If others have a better solution, please post - this approach required me to start fresh in configuring the editor, which wasn't great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.