In order to fix up the broken display of some Word (Windows) files in LibreOffice, I copied over the entire /windows/Fonts path to file:// (using dolphin via kdesu). The file displays better, but now many system fonts seem to display either in bold or italic, but rarely they the way they used to. What did I screw up and how can I revert this?

  • 1
    You copied them where? Sounds like you managed to overwrite some existing fonts. – lynxlynxlynx Aug 7 '12 at 19:57
  • @lynxlynxlynx I'm afraid so :-/ Guess I have to reinstall them, any idea how to do that the least painfully? – Tobias Kienzler Aug 8 '12 at 10:23
  • Check which font packages you have installed, they usually contain ttf in their name. Also check what Opensuse has for ensuring system/package integrity — there's surely a tool to make sure the packages are still fully installed. Alternativelly you can just blankly reinstall all the packages on your system. – lynxlynxlynx Aug 8 '12 at 10:31
  • @lynxlynxlynx I reinstalled all installed font packages, to no avail. Either KDE decided to change my fonts settings on its own or reinstallation does not replace the files that shouldn't have been overwritten. In fact, I did choose to not overwrite any files when I copied over the windows/Fonts directory, so this is really weird – Tobias Kienzler Aug 9 '12 at 7:51

Reinstalling the font packages was futile. Instead, I had to change the KDE Font settings to use non-broken fonts - they were all set to "Sans Serif" which looks the same in bold as in normal. Changing that to a working one like "Free Serif" fixed this, though I would have preferred figuring out what actually went wrong...

update Installing the webcore-fonts package fixed the actual issue of broken Arial, Sans Serif etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.