2

Running Ubuntu 16.04.4 LTS.

On running sudo apt update, the final lines are as follows:

W: GPG error: http://download.opensuse.org/repositories/home:/osmc/xUbuntu_16.04  Release: The following signatures were invalid: KEYEXPIRED 1482381670
E: The repository 'http://download.opensuse.org/repositories/home:/osmc/xUbuntu_16.04  Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

apt-key list shows one key expired:

pub   2048R/70F1BBEA 2014-10-14 [expired: 2016-12-22]
uid                  home:osmc OBS Project <home:osmc@build.opensuse.org>

(For some reason, apt-key list | grep “expired:” returns nothing however.)

Attempting to update this key does not change anything:

$ apt-key adv --keyserver keys.gnupg.net --recv-keys 70F1BBEA
Executing: /tmp/tmp.pOcDAzqSkJ/gpg.1.sh --keyserver
keys.gnupg.net
--recv-keys
70F1BBEA
gpg: requesting key 70F1BBEA from hkp server keys.gnupg.net
gpg: key 70F1BBEA: "home:osmc OBS Project <home:osmc@build.opensuse.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

I also tried running Y PPA Manager and "Try to import all missing GPG keys" but the result was the same.

I'm guessing perhaps I'm running an out-of-date version of Opensuse and need to change it, but I'm uncertain of what it is and how to do this correctly.

1

After adding a third party repository to a /etc/apt/sources.list.d/* file or /etc/apt/sources.list, you need to make sure the corresponding gpg key is inserted into the apt keystore.

wget http://download.opensuse.org/repositories/home:/osmc/xUbuntu_16.04/Release.key -O - | sudo apt-key add -    
sudo apt update  

If that doesn't work because the key really expired, remove the error and warning messages. Open /etc/apt/sources.list.d/osmc-installer.list and add a hash character ( # ) at the beginning of the lines before deb to turn them into comments.

sudo nano /etc/apt/sources.list.d/osmc-installer.list  

Press the keyboard combination Ctrl+O and after that press Enter to save the file being edited. Press the keyboard combination Ctrl+X to exit nano.

Update your list of available software packages.

sudo apt update  
  • Thanks - running the wget and updating fixed this issue. I appreciate it. – stml Jun 12 '18 at 8:44
  • I also didn't add the repository so not sure how that happened, but still learning I guess. – stml Jun 12 '18 at 8:44
  • This solution worked mutatis mutandis on my Debian 9 installation: wget download.opensuse.org/repositories/home:/strycore/Debian_9.0/… -O - | sudo apt-key add - – harlandski Mar 26 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.