0

It used to be that my gnome keyring would go back to being locked after I rebooted and I'd have to enter the passphrase to unlock again, but now it stays unlocked unless I manually lock it with seahorse. How do I restore the old behavior where the keyring relocks on reboot?

1

It turns out that gnome keyring stored the passphrase for my default keyring in a special keyring named "Login", and unlocked that keyring with my login password. The PAM config files for console login and SDDM login use the gnome keyring PAM module. It can be disabled by commenting out the lines containing pam_gnome_keyring.so from all files containing that string in the directory /etc/pam.d; this should make it so that you have to manually enter the passphrase to unlock your keyring.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.