2

I am trying to use Intel's P-State driver for my custom-built kernel (based on Linux 4.4.55). I have enabled the driver in the kernel configuration (by setting the X86_INTEL_PSTATE flag to "*"), but my kernel somehow still uses the old ACPI_CPUFREQ driver. I have verified that intel_pstate.c is compiled to intel_pstate.o in the kernel sources (in /drivers/cpufreq).

I think the intel_pstate driver is enabled by default, but just in case I still tried adding intel_pstate=enable to the GRUB_CMD_LINE_DEFAULT variable in /etc/default/grub.cfg. Nothing changed, however.

What should I do to enable the Intel P-State driver in my kernel? Why is this driver somehow not built-in?

  • Compiled in or as a module? Is the module installed? – ajeh Jun 11 '18 at 22:30
  • @ajeh Compiled in. Only acpi-cpufreq module installed according to lsmod. – Chaotic_evil Jun 12 '18 at 17:22
  • Try blacklisting the other module and see what happens. Failing that, perhaps you can contact the developer hoping they can provide instructions. I assume you made sure that your CPU is compatible with the P-state driver. – ajeh Jun 12 '18 at 17:26
  • @ajeh I have tried blacklisting acpi-freq module, which result in "no or unknown cpufreq driver" according to cpufreq-info. I also tested another server with same hardware configuration running regular 4.4.0 kernel and P-State driver is working fine. – Chaotic_evil Jun 12 '18 at 18:17
  • Most likely, either your particular CPU is blacklisted by the driver, or the firmware isn't providing the information needed for the intel-pstate driver. – Austin Hemmelgarn Jun 12 '18 at 19:12
1

Linux didn't fix this bug until 4.4.0-75.96 I patched a 4.4.137 intel-pstate driver file to 4.4.55 and it works again. The original bug report is at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1674390

  • You originally wrote yours was 4.4.55, something does not add up. – ajeh Jun 20 '18 at 22:18
  • @ajeh I am still using 4.4.55, but I found the fix didn't happen until 4.4.0-75.96, so I backported the change to my 4.4.55 version. 4.4.0.75-96 and 4.4.137 has no change in intel_pstate that I am aware of. – Chaotic_evil Jun 21 '18 at 22:56
  • 4.4.0 is lower than 4.4.55, so something still does not add up. 4.4.55 should have everything that appeared in 4.4.0. What am I missing? – ajeh Jun 22 '18 at 1:42
  • @ajeh My guess is that ubuntu just number kernel version differently. – Chaotic_evil Jun 22 '18 at 16:03
  • 1
    @ajeh 4.4.0.75-95 actually correspond to 4.4.59 which is higher than 4.4.55 check this link people.canonical.com/~kernel/info/kernel-version-map.html – Chaotic_evil Jun 22 '18 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.