0

I used Handbrake to re-encode some videos. Because of a bad preset the audio got screwed up. I still have the original, so I wanted to copy the "good" audio stream onto the "better" video like this:

ffmpeg -i good_audio.mkv -i better_video.mkv  -map 0:a -map 1:v -map 0:s -c copy test.mkv # subtitles are 

However, when I try to watch the video I get the following error with vlc.

Failed setup for format vdpau: hwaccel initialisation returned error.
[00007f8f90c1add0] avcodec decoder error: existing hardware acceleration cannot be reused
[00007f8f90c1add0] main decoder error: buffer deadlock prevented

The audio works fine, but once you try to skip within the video, it gets muted for a while.

Details about "good" audio stream:

Stream #0:1(jpn): Audio: aac (LC), 44100 Hz, stereo, fltp (default)
Metadata:
  BPS             : 127999
  BPS-eng         : 127999
  DURATION        : 00:23:35.117000000
  DURATION-eng    : 00:23:35.117000000
  NUMBER_OF_FRAMES: 60944
  NUMBER_OF_FRAMES-eng: 60944
  NUMBER_OF_BYTES : 22641870
  NUMBER_OF_BYTES-eng: 22641870
  _STATISTICS_WRITING_APP: no_variable_data
  _STATISTICS_WRITING_APP-eng: no_variable_data
  _STATISTICS_WRITING_DATE_UTC: 1970-01-01 00:00:00
  _STATISTICS_WRITING_DATE_UTC-eng: 1970-01-01 00:00:00
  _STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
  _STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.