1

I have an old (~8years) eeepc 1002HA, laptop with intel atom processor and 160GB HDD. I am trying to install debian 9.4.0, from a iso image that I flashed on a pendrive. The live version seems to work just fine, but the installation fails at installing the system. I do not intend to dual boot with any other OS. I have tried several ways to partition the disk (single partition, separate partition for /home, partition with LVM, without LVM), but the installation always fails. I was wondering if the problem could be related to the pendrive I have been using to install the OS, in fact I see it among the detected drives in the installation process, but I am not sure if the installer is trying to install over that.

I would also be interested in installing a slightly older version of debian, but the error is not very informative, so it is difficult to understand what to do. I would be interested in any recommendation about how to trouble shoot the installation or installing previous version of debian or installing another distro.

EDIT:

I have found that the error log is in /var/log/syslog. How can I save it to the pendrive so that this error can be posted to the developers?

The error is:

squashfs error unable to read fragment

I have tried to pass the variables ide=nodma acpi=off but it still fails at the same percentile

  • Which model of eeePC is it? The models behave in different ways. – sudodus Jun 11 '18 at 13:25
  • @sudodus I have edited my question – simona Jun 11 '18 at 13:29
  • I have experience from eeePC 900, and it works with Lubuntu and Xubuntu, but I don't know your model. Let us hope that someone who owns a 1002HA will see you question and answer. (It might help to add the model number to the title too.) – sudodus Jun 11 '18 at 13:38
  • I cannot test installing Debian, because the computer I know is owned by a friend. You could try with another distro (for example Lubuntu 14.04, 16.04 or 18.04). If it works like in eeePC 900, the installation should work, when booted from a USB pendrive (cloned from the iso file). – sudodus Jun 11 '18 at 13:48
0

As the subject stats Debian ' Installing the system' fails.. well I was getting this same error.. being as i'm doing this for a raspberry i'm going to be purchasing. so I have no real experience in this stuff, but have been in the computer industry since 1978 when I was programming on a Dec PDP 11/34 . . That all being said. I was able to re. pair this issue. or should I say solve it.. as follows: I started over with the installation after confirming the hard drive was good. But I choose the 1 partition new user experience ( as I probably should have to start with . ) This time .. it worked. No more errors went right thru .. well hope that helps someone .. seems you can't partition the hard drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.