2

I new in connecting Ethernet with my Linux Mint, WiFi works fine. But I encountered quite a few errors. After spending 2 days searching I failed to connect.

$ uname -a
Linux 'username' 4.13.0-39-generic #44~16.04.1-Ubuntu SMP Thu Apr 5 16:43:10 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

With "Method" Automatic DHCP, Here are the output of ifconfig

Method: Automatic(DHCP) for Profile

$ ifconfig
enp3s0    Link encap:Ethernet  HWaddr 54:ee:75:79:b7:1f  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:1760 errors:0 dropped:8 overruns:0 frame:0
      TX packets:136 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:147427 (147.4 KB)  TX bytes:17994 (17.9 KB)
      Interrupt:43 Base address:0xd000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:4120 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4120 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:341414 (341.4 KB)  TX bytes:341414 (341.4 KB)

wlp2s0    Link encap:Ethernet  HWaddr 78:0c:b8:d6:62:da  
          inet addr:192.168.43.121  Bcast:192.168.43.255  Mask:255.255.255.0
          inet6 addr: fe80::e842:14d2:88e2:1321/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16271 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13247 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:19535354 (19.5 MB)  TX bytes:1753988 (1.7 MB)

Also with this, the Wire never shows Connected but instead shows Connecting....

I then changed it to Manual with following details shown in attached Image:

Profile with Manual Settings

I then executed pppoeconf command and it executed with no errors.

And here is the output of ifconfig

enp3s0    Link encap:Ethernet  HWaddr 54:ee:75:79:b7:1f  
          inet addr:192.168.43.121  Bcast:192.168.43.255  Mask:255.255.255.0
          inet6 addr: fe80::56ee:75ff:fe79:b71f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1863 errors:0 dropped:9 overruns:0 frame:0
          TX packets:186 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:157640 (157.6 KB)  TX bytes:25158 (25.1 KB)
          Interrupt:43 Base address:0xd000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:4485 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4485 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:370644 (370.6 KB)  TX bytes:370644 (370.6 KB)

wlp2s0    Link encap:Ethernet  HWaddr 78:0c:b8:d6:62:da  
          inet addr:192.168.43.121  Bcast:192.168.43.255  Mask:255.255.255.0
          inet6 addr: fe80::e842:14d2:88e2:1321/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:91264 errors:0 dropped:0 overruns:0 frame:0
          TX packets:61200 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:126022999 (126.0 MB)  TX bytes:7032850 (7.0 MB)

$ netstat -rn

$ natstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.43.0    0.0.0.0         255.255.255.0   U         0 0          0 enp3s0

$ route

$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.43.0    *               255.255.255.0   U     100    0        0 enp3s0

$ cat /etc/network/interfaces

$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto dsl-provider
iface dsl-provider inet ppp
pre-up /bin/ip link set enp3s0 up # line maintained by pppoeconf
provider dsl-provider

auto enp3s0
iface enp3s0 inet static
address 192.168.43.121
netmask 255.255.255.0
network 192.168.43.0
bradcast 192.168.43.255
gateway 192.168.43.1

$ cat /etc/resolv.conf

$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

$ ping 127.0.1.1

$ ping 127.0.1.1
PING 127.0.1.1 (127.0.1.1) 56(84) bytes of data.
64 bytes from 127.0.1.1: icmp_seq=1 ttl=64 time=0.071 ms
64 bytes from 127.0.1.1: icmp_seq=2 ttl=64 time=0.061 ms
64 bytes from 127.0.1.1: icmp_seq=3 ttl=64 time=0.062 ms
64 bytes from 127.0.1.1: icmp_seq=4 ttl=64 time=0.062 ms
64 bytes from 127.0.1.1: icmp_seq=5 ttl=64 time=0.029 ms
^C
--- 127.0.1.1 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4083ms
rtt min/avg/max/mdev = 0.029/0.057/0.071/0.014 ms

$ ping google.com

$ ping google.com
ping: unknown host google.com

$ ping 192.168.43.1

$ ping 192.168.43.1
PING 192.168.43.1 (192.168.43.1) 56(84) bytes of data.
From 192.168.43.121 icmp_seq=1 Destination Host Unreachable
From 192.168.43.121 icmp_seq=2 Destination Host Unreachable
From 192.168.43.121 icmp_seq=3 Destination Host Unreachable
^C
--- 192.168.43.1 ping statistics ---
5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 4100ms
pipe 4

I even tried to ping using the IP Address of google.com

 $ ping 172.217.10.110
connect: Network is unreachable

Update:

Is this be useful? after suggested by one of the answers, I tried

$ sudo ip r a default via 192.168.43.1
$ netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.43.1    0.0.0.0         UG        0 0          0 enp3s0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 enp3s0
192.168.43.0    0.0.0.0         255.255.255.0   U         0 0          0 enp3s0

and I pinged google.com with Name:

$ ping google.com
ping: unknown host google.com

with IP Address:

$ ping 172.217.10.110
PING 172.217.10.110 (172.217.10.110) 56(84) bytes of data.
From 192.168.43.121 icmp_seq=1 Destination Host Unreachable
From 192.168.43.121 icmp_seq=2 Destination Host Unreachable
From 192.168.43.121 icmp_seq=3 Destination Host Unreachable
^C
--- 172.217.10.110 ping statistics ---
5 packets transmitted, 0 received, +3 errors, 100% packet loss, time 4078ms
pipe 4

Please let me know how to resolve this issue.

2
  • 2
    Change addres to address in your /etc/network/interfaces
    – GAD3R
    Commented Jun 9, 2018 at 11:44
  • I updated the Question, it was a typing error. The problem still exists. Commented Jun 9, 2018 at 15:49

3 Answers 3

2

You have no default gateway:

ip r a default via 192.168.43.1

Nor resolver, as - I guess, you have no running DNS service on 127.0.1.1:

echo nameserver 8.8.8.8 >> /etc/resolv.conf

5
  • When I run this command, $ sudo ip r a default via 192.68.43.1 RTNETLINK answers: Network is unreachable Commented Jun 10, 2018 at 4:40
  • Also there is another thing I noticed, as soon as I boot my system, it displays "Wired Connection Established" with some profile which vanishes once I turn off and then turn on the Wired option even though I have not connected any Ethernet. After Once Turning off and then on, the third option vanishes and after that it remains "cable unplugged". What to do? Commented Jun 10, 2018 at 4:44
  • 192. 168 .43.1 not 192. 68 .43.1 Commented Jun 10, 2018 at 4:47
  • Still no effect. When I try to ping, it pauses for a while and after a few seconds again gives the previous output. What should I do? Commented Jun 11, 2018 at 5:39
  • Apparently 192.168.43.1 is not your gateway. Commented Jun 12, 2018 at 7:43
0

go to wired settings at the top where there is the wifi symbol you will be redirected to the network settings click on the setting symbol of your ethernet then remove profile and then create a new profile and edit ipv4 setting add the following to the dns 8.8.8.8, 8.8.4.4 'make sure it is set to dhcp(automatic)

this worked for me

0

I've had this problem, but as i inspected the available network interfaces, i came to realize that my ethernet interface didn't obtain an ipv4 address. Even when i've assigned a static IP address to the wired ethernet connection with nm-connection-editor, nm-tui didn't activate the ethernet connection, and instead raised the IP configuration could not be reserved (no available address, timeout, etc.) error. Anyhow, i've watched the network interface via watch -n 1 ip addr show eno1, then after fiddling with other the end of the ethernet cable i.e. the router, it turned out that its network LAN's DHCP port service is stopped at one of the ports, to which my cable was connected. After unchecking the respective port's check box, the interface gained ipv4 address, and hence network connectivity. Locally at least, then globally.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .