0

Before of all of this, that's what I did :

  • Disabled "Secure Boot" and "Fast Boot" options
  • Created a disk partition, free space of 50GB
  • Used a live USB
  • Programs used : Rufus, Win32DiskImager
  • Installed the ISOs from the official websites

My PC : - Lenovo Ideapad 320-15IAP the specs are these :

https://www.which.co.uk/reviews/laptops/lenovo-ideapad-32015iap

Anyways, at first, I've attempted to install Ubuntu.

I've used Rufus to write the ISO on usb, with the ISO option, the newest Ubuntu release (Bionic Beaver). Also, I did this in EFI USB Mode through Windows Advanced Options (if that's what is called)

So I what I did during the installation :

  1. Used network, Normal Installation
  2. chose the option "Install along side with Windows 10"

and here it goes, it got stuck at installing 'grub2'.

When I say it got stuck, I mean it was like that for ages.

Well, I've decided to power down the laptop, it booted up straight to Windows 10, formatted the partition and gave it a try again. Still same results. I used the "Something Else" option as well, but same bad luck.

I did leave it for a day, hoping that it'd install but nope. Also, tried to install it without Wi-Fi, still nope.

I swear, I've tried every possible way to install this xD

As a result of all this, there's a boot option of ubuntu now, which looks like this : http://terminalinflection.com/wordpress/wp-content/uploads/2012/10/GRUB-Ubuntu.png

Could that be a way to repair the lost ubuntu? Uh, the partitions are already deleted. So, I guess it wouldn't work, anyways, as part of the solution of this problem, how can I get rid of this boot option ? Or else, is there a way to rescue this poor thing?

Soooo, I gave up on Ubuntu, wrote Kali Linux 2018.2 on usb, ran it as EFI USB Mode, normally, I was expecting it to have a "Graphical Install" option as many people recommend to install it that way, but it had a "Start Intaller" option, so I went with that option, everything went "almost" well, so as you have already guessed, this 'grub2' stuck, again and again.

( NOTE2 : I've used Rufus to write ISO for Kali Linux EFI, but faced a problem during installation something related to CD, can't remember exactly. Went for DD option instead the problem with the CD was solved, but the 'grub2' was not. But then used Win32DiskImager, still same issue.)

I did the installation of Kali Linux again but with Legacy Mode this time. Graphical install, the installation went fine af, BUT, it now boots up straight into Windows 10, without any boot menus, as expected "grub menu".

The 'ubuntu' as mentioned earlier still exists as a boot option. The partitions that were created in Kali Linux Legacy mode during installation which was partially successful, haven't removed them yet.

I don't know what else to do, someday I swear I will remove this Windows 10.

I would like to have an explanation of this whole 'grub2' thing, both Ubuntu EFI and Kali Linux EFI stuck at the same step.

I came cross to an idea that EasyBCD could restore the missing Kali Linux legacy grub menu. I'm going to give it a try right now, I will keep you updated.

[UPDATE 1: As I said, I'd try out EasyBCD, uh because Windows is in UEFI regardless if the system is in Legacy mode or not, can't make any changes or add a new entry, so yeah...]

closed as unclear what you're asking by 0xC0000022L, Jesse_b, G-Man, αғsнιη, Satō Katsura Jun 11 '18 at 7:13

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Kali linux is a very bad idea, and Ideapad is fairly well supported by Linux. You must be messing up something not fairly obvious. Use an Ubuntu instalation image instead of trying a live one from any distro. – Rui F Ribeiro Jun 9 '18 at 10:16
  • Thanks for your response. Even though, I did as you say, same issue occurred, it's okay. I found another way to deal with this in which I will post it below. – sadtryhard Jun 9 '18 at 18:01
0

Well, since there's no other way (yet) to dual boot this laptop with Ubuntu or Kali, using a live USB is the best solution (for me). Luckily, my USB works still fine regardless of many re-writes lol.Using a live USB is not bad all, you can still have your windows 10 or whatever.

All you need to do is to write the ISO file with Rufus (or Win32DiskImager, whatever works for you) onto your USB. Then you can either boot it up by Windows Advanced Startup or just change the boot priority of your BIOS.

And when the linux operating system of your choice loads up to boot menu, you can just choose the "Live System" option (for Kali) or Try using (for ex. Ubuntu) without installing.

However, if you're willing to save files, or some work. The Live/Test System will not keep your files. Each time you boot it up, it's going to be like a new fresh system. In order to make your little live USB a portable operating system, you have to make it persistent.

There's a guide on how to make a Live USB with Persistence on Kali Linux 2018 : https://devanswers.co/guide-kali-linux-2018-live-usb-persistence-windows/

[EDIT1] Just found an article for Ubuntu : https://www.howtogeek.com/howto/14912/create-a-persistent-bootable-ubuntu-usb-flash-drive/

In case you want to create a different Linux system with Live USB Persistence, you can use your favorite search engine to look up guides.

By the way, I'm not a Linux expert or whatever, I'm just posting a way that worked for me, and probably it will work for you too. But, in any case I advice you to search it a little bit more, maybe you can find something.

That's all for now, correct me if I'm wrong xd

Anyways, don't give up on trying, you're going to do it c:

Not the answer you're looking for? Browse other questions tagged or ask your own question.