0

I am pulling out my hair trying to solve this. I haven't connected a Linux system to a windows share in a while. But when 1803 came out, windows shares disappeared across the board. Even Windows machines couldn't see each other. That headache was solved by enabling automatic services that were set to manual for some reason.

Well, now I'm wanting to introduce a Linux box back into the mix for a home automation hub. Well, either I forgot how to and everyone else has bad advice or the update broke more than just the talk between themselves.

I have tried three different distros: Deepin (on a VB VM), Rasbian, and Armbian Jessie and Xenial (on a Pine64, currently running the Xenial). None of them see any of the Windows machines. On the host windows machine, I set up a folder called "myshare" and gave full permissions for user "test" with a pass "test". Hard to screw up that login. Computer Name = "ShadowLAN-HSVR", ip = "192.168.1.52", Workgroup = "SHADOWNET", No domain.

It's on a private connection Network discovery is "on" File and printer sharing is "on" Guest or Public everything is "off" Public Folder Sharing is "on" File sharing connections were bumped from "128-bit" to "40/56 bit" as per a suggestion Password Protected Sharing turned "off" as per a suggestion

All windows computers can access this share.

On the Linux box I've tried:

sudo smbclient -L 192.168.1.52 -m SMB3 -U test

I got:

Domain=[SHADOWLAN-HSVR] OS=[] Server=[]

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    D$              Disk      Default share
    Downloads       Disk
    E$              Disk      Default share
    Encryption      Disk
    IPC$            IPC       Remote IPC
    Media           Disk
    Movie Processing Disk
    myshare         Disk
    Users           Disk
Connection to 192.168.1.52 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled -- no workgroup available

tried:

sudo smbclient -L ShadowLAN-HSVR -m SMB3 -U test

Got:

Domain=[SHADOWLAN-HSVR] OS=[] Server=[]

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    D$              Disk      Default share
    Downloads       Disk
    E$              Disk      Default share
    Encryption      Disk
    IPC$            IPC       Remote IPC
    Media           Disk
    Movie Processing Disk
    myshare         Disk
    Users           Disk
Domain=[SHADOWLAN-HSVR] OS=[] Server=[]

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------

The mount is set for /home/admin/myshare

fstab has

//192.168.1.52/myshare /home/admin/myshare cifs username=test,password=test,sec=ntlmv2,vers=3.0 0 0

set for ver 3.0, but have tried 2.0 and 2.1 with no change. Also sec has been ntlm or just not included. No change.

I've tried:

sudo mount -a

Results:

mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

It and the VM, as I said, does not see any computer. "Workgroup" shows up, but they show the Linux shares on the VM only.

I really need this to work because I'm wanting to rsync backup to it and also will be accessing media files on it (Dinner Music).

  • Just to be sure, did you ser network and ntfs permissions? – Nasir Riley Jun 9 '18 at 1:51
  • Right-clicked on the shared folder on the host, went to sharing>advanced sharing, it is shared. Went to permissions, test is full control. BUUUTTTT... Under security, test was NOT there. Added the user, full permissions (didn't add as owner), fired up terminal on the Pine64, mount -a, and voila, no errors. In the DE, mounted fine and found the test file. Always good to have a second pair of eyes when you're frustrated. I'm going to change user info for the actual login, fire up the credentials file link in fstab, and see if things don't hiccup again. Thanks. – ShadowHawk Jun 9 '18 at 17:48
  • Glad to help. I'll add my suggestion as an answer where you can accept it in case anyone else might need help with an issue like yours. – Nasir Riley Jun 9 '18 at 19:27
0

The permissions for your user need to be set in both Properties -> Sharing -> Network Sharing and also in Properties -> Security.

  • Didn't have this then, but permissions came up later as a problem again. This time I added the step Give access to -> <username> and it worked. Thanks again. – ShadowHawk Jul 28 '18 at 11:18
  • @ShadowHawk You are welcome. Glad to help. – Nasir Riley Jul 28 '18 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.