1

I am running openSUSE Tumbleweed and would like to use xfce as my desktop environment. GNOME works flawlessly, but I am having a big problem with xfce.

The problem is that xfce crashes on the launch of certain applications such as Firefox, Dragon Player, and others. When I attempt to launch one of these applications, I get a blank black window and xfce freezes. I can only get out using ctrl-alt-backsp. The strange thing is that after I execute that key combination, I momentarily see the desktop as it really should be, e.g. Firefox with my home page displayed and then I'm out.

This doesn't happen with all applications. I can still load the various settings without problems, Chromium browser works, the terminal works, and so does the file browser. I am sure there are others that work too.

Any ideas would be greatly appreciated. Thank you.

  • in case it's related with 3D, try disabling xfce's display composing: (xfce4-settings-manager -> Window Manager Tweaks -> Compositor ). If this "solves" it, it would mean it's related to the 3D drivers – A.B Jun 8 '18 at 21:17
  • I tried disabling composing, but it did not help. Still the same problem. Thanks for your suggestion. – jeo15 Jun 9 '18 at 2:27
  • I tried to install LXDE, and I have the same problem with LXDE as with xfce. GNOME and KDE work fine. – jeo15 Jun 11 '18 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.