0

System: Onion Omega2s LEDE 17.01

I have connected a Huawei ME90E modem to the USB port of the Omega2s.

I have successfully connected the ME906E modem to the Raspberry Pi running Debian, but have problems with the LEDE on the Omega2s.

I have tried many times, but still not successful in getting the interface up.

I must have missed something.

Any help is appreciated.

Running dmesg confirms the modem is recognised:

[ 12.556027] usbserial: USB Serial support registered for GSM modem (1-port)

[ 12.563783] option 1-1:2.2: GSM modem (1-port) converter detected

[ 12.570351] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0

[ 12.577378] option 1-1:2.3: GSM modem (1-port) converter detected

[ 12.583884] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1

[ 12.590910] option 1-1:2.4: GSM modem (1-port) converter detected

[ 12.597470] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2

The ports /dev/ttyUSB0, /dev/ttyUSB1 & /dev/ttyUSB2 are created. I run

minicom -D /dev/ttyUSB2 115200

to communicate with the modem and I can connect successfully to the system operator's network by running

AT^NDISDUP=1,1,"apn"

The file /sys/kernel/debug/usb/devices contains

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  3
P:  Vendor=12d1 ProdID=1573 Rev= 2.28
S:  Manufacturer=HUAWEI Technology
S:  Product=HUAWEI Mobile
S:  SerialNumber=0123456712ABCA17
C:  #Ifs= 6 Cfg#= 1 Atr=a0 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=02 Driver=
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=03 Driver=
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=01 Prot=01 Driver=
E:  Ad=84(I) Atr=03(Int.) MxPS=  10 Ivl=32ms
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 3 Alt= 0 #EPs= 3 Cls=0b(scard) Sub=00 Prot=00 Driver=
E:  Ad=85(I) Atr=03(Int.) MxPS=   4 Ivl=32ms
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 4 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=01 Prot=07 Driver=
E:  Ad=88(I) Atr=03(Int.) MxPS=   8 Ivl=32ms
E:  Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 5 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=05 Driver=
E:  Ad=89(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=06(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
C:* #Ifs= 5 Cfg#= 2 Atr=a0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=06 Prot=00 Driver=(none)
E:  Ad=82(I) Atr=03(Int.) MxPS=  16 Ivl=32ms
I:* If#= 1 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
I:  If#= 1 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=03 Driver=option
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=02 Driver=option
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 4 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=05 Driver=option
E:  Ad=85(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
C:  #Ifs= 3 Cfg#= 3 Atr=a0 MxPwr=500mA
A:  FirstIf#= 0 IfCount= 2 Cls=02(comm.) Sub=0e Prot=00
I:  If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=0e Prot=00 Driver=
E:  Ad=82(I) Atr=03(Int.) MxPS=  64 Ivl=32ms
I:  If#= 1 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=02 Driver=
I:  If#= 1 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=02 Driver=
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=05 Driver=
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

The file /etc/config/network was modified to add

config interface 'usb0'
     option ifname 'usb0'
     option proto 'dhcp'

I tried both ways - rebooting the system and running

/etc/init.d/network reload

When the system is up or the network is reloaded, I run ip addr and the usb0 still does not show up

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 1000
    link/ether 40:a3:6b:c0:3a:01 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.149/24 brd 192.168.0.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::42a3:6bff:fec0:3a01/64 scope link 
       valid_lft forever preferred_lft forever
3: ra0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-wlan state UNKNOWN qlen 1000
    link/ether 40:a3:6b:c0:39:ff brd ff:ff:ff:ff:ff:ff
    inet6 fe80::42a3:6bff:fec0:39ff/64 scope link 
       valid_lft forever preferred_lft forever
4: br-wlan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 40:a3:6b:c0:39:ff brd ff:ff:ff:ff:ff:ff
    inet 192.168.3.1/24 brd 192.168.3.255 scope global br-wlan
       valid_lft forever preferred_lft forever
    inet6 fd1d:48c4:7633::1/60 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::42a3:6bff:fec0:39ff/64 scope link 
       valid_lft forever preferred_lft forever
5: apcli0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 1000
    link/ether 40:a3:6b:c0:39:00 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::42a3:6bff:fec0:3900/64 scope link 
       valid_lft forever preferred_lft forever
  • this would probably help (I bet you don't have the QMI parts installed by default, without which only ppp mode can work): How To use LTE modem in QMI mode for WAN connection (OpenWrt Wiki) – A.B Jun 8 '18 at 16:00
  • Actually, kmod-mii, kmod-usb-net, kmod-usb-net-qmi-wwan and kmod-usb-wdm are installed. The system will not create the /dev/cdc-wdm because the usb modem is recognised as a usbserial device. – aobs Jun 9 '18 at 4:28
  • Ok I lost this bet. What you should do is compare what behaves differently between the working case on Debian and the non working case on LEDE. I said QMI, but it could be RNDIS instead (Use RNDIS USB Dongle for WAN connection ) or similar. Just try all the tips and links in wiki. I don't have the hardware to reproduce this, those are only suggestions. – A.B Jun 9 '18 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.