5

I need to install old Debian 5 on my system in order to run some tests. The installation complains regarding bad archive mirror on network. How to solve that problem? Does it means that nobody mirrors the outdated distribution?

enter image description here

  • 1
    Are you trying this URL as repo url: archive.debian.org/debian/dists ? – mariaczi Jun 8 '18 at 9:17
  • 1
    "I need to install old Debian 5 on my system in order to run some tests. ". It might be interesting to know what tests... – user8779 Jun 10 '18 at 10:56
8

At the configure the package manager step you should select (in top of the country mirror list):

enter information manually

Then select a debian mirror from here , for example:

archive.debian.org

Then the Debian mirror directory:

/debian/

You should ignore the next error saying :

security.debian.org couldn't be accessed

because there is no security updates for debian Lenny.

| improve this answer | |
5

Old releases aren’t kept on the main mirror network; you need to use http://archive.debian.org/debian/ instead.

Depending on what you’re trying to test, you might find it easier to use debootstrap instead:

wget http://archive.debian.org/debian/pool/main/d/debian-archive-keyring/debian-archive-keyring_2010.08.28\~lenny1_all.deb
dpkg -x debian-archive-keyring_2010.08.28\~lenny1_all.deb lenny-keyring
sudo debootstrap --keyring=lenny-keyring/usr/share/keyrings/debian-archive-keyring.gpg lenny lenny http://archive.debian.org/debian/

will create a Debian 5 base installation in a lenny sub-directory in the current directory.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.