1

I have the bare minimum Arch Linux install with a wired connection. I can’t seem to obtain an IP address with netctl. I created an eth0 profile with ethernet-dhcp. I tried to start the profile but the control process exited with error code. When I look at the status of netctl it says it exited with error code. I can restart netctl but it still has the same error. What can I do to figure out why I can’t get an IP with netctl?

  • Could you add the error code and the content of /etc/netctl/Your_profile – GAD3R Jun 8 '18 at 10:04
  • I ended up switching back to dhcpcd – user21303 Jun 8 '18 at 10:04
1

have you tried specifing the DHCP on the netctl profile?

Description='A basic dhcp ethernet connection'
Interface=enp30s0 (USE YOUR INTERFACE)
Connection=ethernet
IP=dhcp
DHCPClient=dhcpcd

If dhcpcd doesn't work for you you can try using dhclient

Another way of fixing this might be to bypass netctl and just launch dhcpcd/dhclient (i really suggest dhclient) to configure the interface for you

have you tried reading the official netctl documentation for dhcp troubleshooting?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.