2

I am on Manjaro with Cinnamon as DE, so I use Nemo as my file manager. Whenever I double-click markdown (.md) files, I get a dialog asking if I want to execute the file or edit in a text editor. The default editor associated with .md is Typora.

I understand that this is partly because the execute flag is set on the file; if I remove the execute permission the file opens in Typora like I expect with no dialog prompt. However, this is not practical as a solution:

  • Seems like Nemo creates files with execute set by default, so disabling it every time is tedious.
  • I notice that some file systems don't seem to allow unsetting the execute flag, such as encrypted volumes.
  • I may want to keep a file executable and have the default behavior be opening it in an editor.

Surely somewhere there must be a setting to the tune of "Default behavior for executable files: Display/Run/Ask". Where is this?

1 Answer 1

1

It's actually more like Run/View/Ask. :)

Go to Edit > Preferences > Behavior tab. In the Executable Text Files section, you should find the options you're looking for. It's a global setting, so it can't be applied to just a single file type. Also, setting to view by default apparently prevents executing the files from within Nemo.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .