0

I just installed archlinux (4.16.13-2-ARCH). After some configurations concerning the wifi and the users, I decided to install a GUI: GNOME.

I started by installing xorg-xinit, xorg-server and xorg-apps. I created a .xinitrc file in my ~/ by copying it from /etc/X11/xinit/xinitrc. I modified the .xinitrc file by commenting the lines from tvm to the end (as indicated in the official Archlinux documentation: https://wiki.archlinux.org/index.php/Xinit). And at the end of this file, I added this: exec gnome-session.

For now, I do not want to use GDM because I want to have my terminal from the beginning.

So after modifying this file and after login by tty, I launched the startx command.

GNOME launches correctly (I believe it) after a time that I find long (1 minutes, is this normal with an SSD?). But when I click on "settings" or on the application "cheese" for example, the mouse cursor becomes a loading wheel and ... All Freeze! Forced to turn off the PC by the button ...

I admit to being lost, having little knowledge around Linux ... I read a lot of messages on forums but nothing seems to stick to my problem. If anyone has an idea of ​​where to look or what's going on, I'm interested!

  • Can you still kill the X server with Ctrl+Alt+Backspace to avoid the hard reboot at least? Can you switch to one of the TTYs? – 0xC0000022L Jun 9 '18 at 12:12
  • I find solution: my Graphic Driver wasn't installed. Work better with NVIDIA driver and Bumblebee. – Neau Adrien Jun 9 '18 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.