1

I'm running pppd in a Ubuntu VM. When it's connected the ip route is like this

# ip route
default via 192.168.154.2 dev eth0 onlink
XX.XX.250.5 dev ppp0  proto kernel  scope link  src XX.XX.250.43
172.16.177.0/24 dev eth1  proto kernel  scope link  src 172.16.177.200
172.17.0.0/16 dev docker0  proto kernel  scope link  src 172.17.0.1 linkdown
192.168.154.0/24 dev eth0  proto kernel  scope link  src 192.168.154.200

The eth0 is the default route out

# ip route get 8.8.8.8
8.8.8.8 via 192.168.154.2 dev eth0  src 192.168.154.200
    cache

Now, I need to route everything through ppp0 (except for the remote PPP server), any ideas?

P.S I've tried the following and it just cut all internet connections,

route add default gw XX.XX.250.5
2

Problem resolved.

Simply instruct sstpc to save server route by adding the --save-server-route parameter and let pppd replace the default route by enabling the replacedefaultroute option.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.