2

I know this has been asked, but I believe my case is different. I've had windows 10 and ubuntu 16 dual booted on my laptop, and I just installed kali for a class, making triple boot. It will prompt me for user name and password but it will either get stuck on a grey background, or go to a black screen and then back to prompting me for the username password.

Some general solutions suggest to install lightdm and that will fix the problem, but I can't connect to wifi, and have no ethernet cable. ctrl + alt + f2 still pops up a terminal, but just about any command I run (and even when I'm not running anything) will get a watchdog error or something like "watchdog: bug: soft lockup - cpu#1 stuck for 22s!"

Any solution? My other operating systems still work just fine. I can give more details about the watchdog error (it's prints a lot of stuff).

Anything helps, I've been on this problem for a while now. If it makes a difference, when I made the bootable drive, I used rufus and told it to install as DD instead of ISO (since the ISO wouldn't mount the cdrom partition or something like that).

EDIT: Some people are hinting that the solution to this problem is to just install a different distro, since kali isn't for the laymen or whatever. I disagree. I learned a lot solving this issue and I urge you to try and tackle yours too. Thanks everybody.

10
  • What user are you trying to log in with? What do the logs say? – multithr3at3d Jun 6 '18 at 0:03
  • If you have a soft lockup, then you've likely got a kernel bug (triggered by some combination of hardware/software). Such things are only addressable by the kernel maintainers. So you're going to have to report to either Kali, or if it's a vanilla kernel, to the Linux kernel maintainers. – phemmer Jun 6 '18 at 1:06
  • I would either 1) download packets to from Ubuntu 2) format that from Ubuntu 3) Install on top of Kali a better distro, like SuSE, or if you insist in Kali, reinstall a new version on top of it. – Rui F Ribeiro Jun 6 '18 at 2:18
  • @Patrick Either the installation is botched or it needs a kernel parameter, and the last option seems more unlikely as Ubuntu is running fine. Please do not advise rookies filling up bug reports, a rookie wont be able to do it on the detail needed and bug reports are not meant for end user helpdesk. This error could be for the OP overclocking the machine. – Rui F Ribeiro Jun 6 '18 at 2:20
  • 1
    Possible duplicate of Why is Kali Linux so hard to set up? Why won't people help me? – schily Jun 6 '18 at 10:44
7

OK I found that this is actually 2 separate issues, and I'm going to step by step walk through the steps I used to solve these issues simultaneously, but if you only have 1 of the issues, you should be able to extract just the parts that matter to you, and maybe you can do this in a more efficient matter.

The first issue is the watchdog bug issue (which just needs an additional kernel boot parameter), and the second issue is the stuck-on-grey/black/whatever problem, which is an issue with some software/driver that communicate with x-server (or something like that, I'm not a pro).

Pre requisites: make sure you're around the same wifi (or ethernet) that you used to install kali (other wise you can connect through the command line but I never have good luck with that).

1) Restart the computer and once in GRUB mode, move the selection to Kali, then click 'e'

2) Move down to the line that starts with 'linux', and at the end add 'nouveau.modeset=0'. This will solve the watchdog error, but this is only a temporary fix.

3) Press f10 to boot into kali

4) Don't log in to the gui log in. Wait for the wifi to connect (you can check on the top right corner) then hit CTRL-ALT-f2 to open a terminal and log in as root (you shouldn't see the watchdog bug).

5) type the following commands to fix the x-server issue (use sudo if you're not root):

sudo apt-get purge lightdm
sudo apt-get update
sudo apt-get install lightdm

It should ask you to pick between lightdm and gdm3 or something, pick lightdm

6) Restart with

shutdown -r now

and repeat steps 1-3 (that temporary watchdog fix).

7) Now to permanently add that parameter, open up a terminal and type

sudo vim /etc/default/grub

(I use vim, but you can use nano, leafpad, whatever you like) And look for the line starting with GRUB_CMDLINE_LINUX_DEFAULT

and add the "nouveau.modeset=0" to the end, inside the quotes with the other parameters like

"....other parameters...... nouveau.modeset=0"

8) run

sudo update-grub

And you should be good. I hope I saved you some time.

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.