3

I'm not so new to Linux in general, but I am new to Arch. I've installed it twice (the first time on an HDD, just to try while waiting for the SSD to be delivered to me, the second time, a few days after, on the SSD), with i3 and other programs in order to have a usable desktop environment. By the way, my choices were based on the match between my taste (Vim-addicted) and pure readings of the official Arch wiki pages.

At the moment there's one thing that is annoying me tremendously: when I open Spotify (installed from AUR, trough aurman -S) or Qutebrowser (official, through sudo pacman -S) and, possibly, other applications, either from the terminal urxvt or through rofi, I experience a complete "freeze" of the keyboard which lasts for as long as fifty seconds (!), while the mouse still interacts perfectly with the environment. For instance, I can do this funny thing:

  1. Open Spotify, then
  2. Keep doing anything on the keyboard with the left hand, e.g.
    • keep pressing 1 and 2 alternatively and frenetically with a finger while holding down $mod, which is Alt in my case, with the thumb,
    • or randomly press letter keys while in a text box in the browser or in the innocent terminal
    • or, just to be clear about what I've tried, pressing my angry cat on the whole keyboard
  3. In the meanwhile, use the right hand to successfully move from one workspace to another with the mouse (using the numbered icons in the bottom-left part of the screen), and interact with any mouse-interactive stuff (next song, raise volume, change audio output in pavucontrol, ...). Obviously, should I move to a workspace with a full-screened program, I would be stuck in that workspace until those long fifty (more or less) seconds pass by.
  4. The keyboard starts working again and it is as I never pressed those keys (e.g. if I was pressing letters while in the terminal, those "past" letters do not appear).

The keyboard is a wireless Logitech K270 (with the wireless M185 mouse from the same box) with a USB receiver, but I honestly don't know what other details I could provide, so please ask me. (I don't really think that the filesystem could play any role in the matter but, should I be wrong, it's btrfs.)

My motherboard is a X399 Aorus Gaming 7, and has

  • 1 x white USB 3.1 Gen 1 Port (from the user's manual, while it's labeled as USB 3.0 BIOS on the I/O shield, since it's the Q-Flash port aimed at flashing the BIOS)
  • 5 x blue USB 3.1 Gen 1 Ports (from the user's manual, while they're labeled as USB 3.0 on the I/O shield)
  • 2 x yellow USB 3.1 Gen 1 Ports (from the user's manual, while it's labeled as USB 3.0 DAC-UP on the I/O shield)
  • 1 x red USB 3.1 Gen 2 Type-A Port (from the user's manual, while it's labeled as USB 3.1 on the I/O shield)

The 9 ports are disposed in couples as in (letters = colors)

YY
WB
BB
BB
 R
1

I'm posting this self-answer since it represented a solution for me, so far, and could help someone else who is looking for answers without paying enough attention to the question, but I'll wait for some guru to give an explanation to this strange problem.

After having connected a wired PS/2 port keyboard and verified it's not affected by this problem, I tried moving the receiver from lower-left-most blue USB port to the red one. This worked. Then I checked the keyboard package for some info about USB, but not even a dotten number like 2.0, 3.0, or whatever was on there, so I just kept trying. The white port, then the yellow ones, and other blue ports. The keyboard works perfectly with every single USB port except that one, the first I tried.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.