1

I'm attempting to install RHEL7 on an old HP ProLiant DL585 G2 server. I boot into the installer through optical media and everything loads correctly as far as I can tell, however the installer does not detect a disk. I suspect this is because the server is using an HP SmartArray P400 hardware raid controller, and the installer doesn't have a driver.

Apparently support for these old drivers (CCISS) was discontinued in favor of newer drivers (hpsa) which do not support the P400. This page links to a sourceforge with various drivers as a possible solution, but I'm unsure how to proceed from there, or if it's possible at all. I'm fairly inexperienced even using Linux, let alone administration. Can someone point me in the right direction?

Other Considerations

I'm trying to mimic an offsite environment that our code will be running on later. The install disk was given to us by the admins of the other environment, and has all the packages they are running. Communication is practically nonexistent, and we don't have much time to access the other environment once our window starts, so working out the kinks now is preferable.

That said, installing an older version of RHEL defeats our purposes. Currently this server is running CentOS 6.9, which I installed without any issues.

6
  • 2
    Have you checked the HPE firmware to make sure the raid disk is configured? It should be F8 during the boot up process but after POST. Even though a DL580G7 is a few years newer but still uses the HP SmartArray P400 and we have RHEL 7.4 installed on it. – thebtm Jun 5 '18 at 19:04
  • Yes. I checked, and a single logical drive already exists. But the fact that you're running RHEL 7.4 does make me hopeful that it's possible on my hardware – automaton Jun 5 '18 at 19:33
  • I have an HP380G6 with a similar issue at first boot. So I had to enter the RAID bios & set each disk to raid0 to be able to detect them... this process looks stupid but it is the solution. On some older machine you olso have to set disk graps & detect them (not each disk independant) – francois P Jun 6 '18 at 5:37
  • Try booting with kernel parameter hpsa_allow_any=1 and/or hpsa_simple_mode=1 which may allow the module to access unknown HP Smart Array hardware. – wurtel Jun 6 '18 at 12:06
  • @francoisP The only logical disk in the RAID controller settings is already set to RAID 0 =/ – automaton Jun 6 '18 at 18:10
3

In large part, the answer comes from this forum post. I'll fill in some minor gaps for anyone with similar experience levels seeing this in the future.

As per the comments on the original question, before you start make sure your RAID is configured. You can access the UI by pressing F8 during system boot. It may be necessary to set the disk to RAID 0.

Boot from your installation media. With Install RHEL 7.x selected, press tab to edit the install options. Add hpsa.hpsa_simple_mode=1 and hpsa.hpsa_allow_any=1 to the options. (Simple Mode may or may not be necessary.) This allows the OS to access the hardware with its installed HPSA drivers as opposed to the CCISS drivers. Press enter to start installation.

Install as normal. When the system reboots after install it will fail, as it no longer has the boot options that let it use the RAID. Boot from the installation media again. Choose Troubleshooting. Select the Rescue a RHEL system and press tab, adding the same option(s) as before, and press enter.

Change to the installed system (from the rescue system you're currently running) with chroot /mnt/sysimage. Use nano or vim to edit the GRUB2 config file, e.g. run nano /etc/default/grub. One final time, add the option(s) from before to the GRUB_CMDLINE_LINUX entry. Save the file and exit. Remake GRUB2 with grub2-mkconfig -o /boot/grub2/grub.cfg.

Exit the shell and reboot your system. You may get a message about SElinux relabeling the first time it boots, which may or may not give progress indication. Give it a generous amount of time to complete.

Congratulations, RHEL/CentOS 7 should be up and running!

It doesn't affect your running system, but if seeing the option on startup bugs you, you can remove the rescue image from your system as well.

1
  • There is not need to boot into Troubleshooting -> Rescue mode. Simply, let the system boot from the disk and modify the Grub boot option. Once in the system, edit /etc/default/grub, remake Grub and reboot to test it. – aPugLife Dec 12 '19 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.