3

I am trying to install moreutils on Red Hat Enterprise Linux 7.4, but it is complaining about a dependency on perl(IPC::Run). Here is the command I'm running and the error message I am receiving:

# /bin/yum -d 0 -e 0 -y install moreutils
Error: Package: moreutils-0.49-2.el7.x86_64 (epel)
           Requires: perl(IPC::Run)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

I've tried searching for the package perl-IPC-Run but it does not seem to be available.

4

It turns out Perl-IPC-Run is in the rhel-7-server-optional-rpms repository which had not been enabled.

These are the steps I took to fix the issue:

# subscription-manager repos --enable=rhel-7-server-optional-rpms
Repository 'rhel-7-server-optional-rpms' is enabled for this system.
# yum search Perl-IPC-Run
...
perl-IPC-Run.noarch : Perl module for interacting with child processes

Now the Perl-IPC-Run package is available and moreutils installs without an error.

-1

I have downloaded perl-IPC-Run-0.84-2.el6.rfx.noarch and issue was fixed http://rpmfind.net/linux/rpm2html/search.php?query=perl-IPC-Run

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.