1

This issue is on centOS 7.

I configured the proxy address following this process!, post which the network was working fine.

But, I need few domain sites excluded from proxy. So, I added the following line to /etc/profile.

export no_proxy="127.0.0.1, localhost, *.org.in"

Curl to those sites didn't work.

[raj@hostname ~]$ curl -sk http://app.org.in/

Network Error

Network Error (dns_unresolved_hostname)

Your requested host "app.org.in" could not be resolved by DNS.

I tried with --no-proxy argument, and it worked.

[raj@hostname ~]$ curl --noproxy "*" -sk http://app.org.in/

Could someone please help me in setting the proxy for not acting on the domain websites.

  • When you say *.domain.com, do you mean * as a wildcard (for www, ftp, and all other words), or as a literal asterisk? I'm not even sure the 2nd would even be a proper domain name. – Ulrich Schwarz Jun 4 '18 at 17:26
  • Sorry for the confusion. Here 'domain' is our client name(which I am covering up). In the example, I'm trying to access a specific application of the client. All our applications end with the client name at the end(supposedly like mail.google.com, drive.google.com,images.google.com..). I am trying to configure proxy such that it wouldn't apply to the applications on the client domain. – Raj Jun 4 '18 at 17:46
2

Solved.

I was appending asterisk(*) in the no_proxy ( *.org.in) which caused the issue. The issue is resolved after removing the *.

Not the answer you're looking for? Browse other questions tagged or ask your own question.