I've got some issues when copying larger files to my USB drive. First of all, my system stopped recognizing my USB drives automatically. I now have to run modprobe usb-storage in order for my USB drive to be recognized.

Once this is run, I can properly access my USB drives (USB pen drives). However, when I try to copy a larger file, the copying process will hang. My USB drive indicates to be busy, and my program also indicates it is writing information, but it simply hangs and does not move. Details:

  • I tried using a GUI tool and the command line. Results are the same.
  • I tried using different USB drives. Results are the same.
  • I tried decreasing the max_sectors setting, as indicated here. This has one main result: instead of hanging at 200 MB, the file now copies for 60 MB instead before hanging.

Given the last observation, I feel it might have to do something with the max_sectors setting, but even lowering this does not help, so I'm not sure exactly where the issue can be. Please note that the system will copy a certain amount of information (60 or 200 MB, or whatever I set max_sectors to), and then act as if more info is being written, while in fact nothing happens. I have to manually remove the USB drive in order to be able to shut down my computer.


Please note that at this moment very few times I'm actually able to have my USB recognized. I am running modprobe usb-storage a dozen times, taking the USB out and connecting it again, and opening my file browser frequently, to try to 'force' recognition/mounting of the drive. It only happens once in many times. I feel this whole thing is related to one main issue with the USB drivers or something else in common, but I'm just not sure what it is. Any ideas?

  • You sure you connected to a e.g USB2.0 port, and the drive works on e.g Windows ?
    – daisy
    Aug 7, 2012 at 6:43
  • Yes, these same ports have worked for the same devices for years. Nothing has physically changed. Also, the same drives work perfectly fine on other computers. Also, other devices (keyboard, scanner, etc) work fine on the same USB ports. Aug 7, 2012 at 12:50
  • 1
    The question was does your USB-drive work on other systems? Not: Do your ports work with other devices. It could be that your USB-drive is "dying" (sounds pretty much like a electronic defect of the drive to me)...
    – Nils
    Aug 7, 2012 at 20:18
  • Check my comment: "Also, the same drives work perfectly fine on other computers." I have tried many different USB drives and they all show the same behavior on the PC in question, whereas they work fine on other machines. Aug 7, 2012 at 22:10
  • man rsync - a fast, versatile, remote (and local) file-copying tool Aug 23, 2013 at 13:14

1 Answer 1


Are you mounting via command line or using your desktop environment? (It's not clear, whether you used GUI/command line for mounting or copying.)

I used to have a similar problem where GNOME decided to unmount my devices all of a sudden. Try mounting using the terminal and see, whether the problem persists. If so, have a look on (and tell us) the output of dmesg before plugging in the device and especially, when the error occurs.

Which filesystem do you have on your device? If it is NTFS, it might be due to your NTFS driver (don't know much about this one, but always think its suspicious). Format your device with ext2 or vfat and try again, to be sure.

Does the problem occur, when overwriting the whole device using dd or cat image > device? (Be sure to not overwrite any other device!)

I am sorry for this should have been rather a comment than an answer, but unfortunately I'm not allowed (yet) to comment.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .