2

I've just installed a fresh new Debian 9 LXDE into an Acer AMD notebook and it seems that all the audio devices were correctly recognized:

root@debian:~# aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: CX20584 Analog [CX20584 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

However, none of these devices are working properly:

  • only a few stuff plays on the headphones, ex:
    speaker-test --device plughw:1,0
    aplay --device plughw:1,0 test.wav
    system beep
  • only a few stuff plays on the HDMI, ex:
    speaker-test --device plughw:0,3
    aplay --device plughw:0,3 test.wav
    system beep
  • no sound from the speakers
  • no volume icon in the bottom task bar

Question

  • Could this be a sound routing issue?
  • Setting the main audio device as default could solve this issue?
  • How to solve that? Any other idea?

Notebook Specifications
Aspire E1-421-0622

  • AMD 2 Core™ Processor E1-1200 (1.4 GHz) 1MB Cache 64-bit Processing
  • AMD Radeon HD 7310 Graphics Controller
  • 2Gb DDR3 SDRAM Memory
  • 256MB shared video memory
  • Atheros HB125 IEEE 802.11b/g/n Fast Ethernet Network Card

Debian Version
debian-9.4.0-amd64-netinst.iso

Software selection

(  ) Debian desktop environment
(  ) ... GNOME
(  ) ... Xfce
(  ) ... KDE
(  ) ... Cinnamon
(  ) ... MATE
(X) ... LXDE
(  ) web server
(  ) print server
(  ) SSH server
(X) standard system utilities

  • Mixer/sound routing issues. Cannot help further. – Rui F Ribeiro Jun 4 '18 at 1:26
  • @RuiFRibeiro Maybe it is something simpler. Ex: The default audio is set to HDMI instead of speaker. Could this cause the problem? – Mark Messa Jun 4 '18 at 1:33
  • That could be a sound routing issue. In my Lenovo in openbsd was set for the headphones only by default. Sound is not my specialty, not able to help – Rui F Ribeiro Jun 4 '18 at 1:34
  • @RuiFRibeiro Do you think that the latest kernel from backports might be the direction? – Mark Messa Jun 4 '18 at 1:49
  • Nah, some sysctl or alsa settings. Não o consigo ajudar mais que isto. – Rui F Ribeiro Jun 4 '18 at 1:52
1

Most likely, alsa is loading the correct modules but setting the wrong sound device as default.

Assign card 1 to index=0 with /etc/modprobe.d/snd-hda-intel.conf containing:

alias char-major-116 snd
alias snd-card-0 snd-hda-intel
alias snd-card-1 snd-hda-intel

options snd-hda-intel id=Generic_1 index=0
options snd-hda-intel id=Generic index=1

After rebooting, the main audio device should be the default:

root@debian:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: CX20584 Analog [CX20584 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Open a terminal and confirm in alsamixer that all channels are unmuted.
Speakers, headphones and HDMI should be working now.


Source: Audio and snd-hda-intel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.