1

After updating to Xubuntu 18 the system started playing sounds when, for example, I cancel a command in Emacs, or the search in HTML page displayed in Firefox fails. This is very inconvenient because this happens a lot and the sound played is very loud.

I don't know what produces this sound. Kernel module pcspkr is not loaded. I tried

xset -b
xset b off

Which also had no effect.

This is not a problem specific to console, however, console applications also play sounds.

When I tried set zeroth channel of alsa mixer to mute:

amixer set channel 0% mute
amixer: Unable to find simple control 'channel',0

But when I look at the output of amixer:

Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]

I looked at Settings > Appearance > Enable Sound Events, but it's not ticked...

Short of opening the case and cutting off the beeper, I don't know what else to try. Any ideas?

  • For me unloading pcspkr as described on the ArchWiki worked. What is the output of lsmod | grep pcspkr? – Devon Jun 6 '18 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.