18

When I turned on my Ubuntu 18.04 yesterday and wanted to start GitKraken, it did not work. After I click its icon I see how the process tries to start in the upper left corner (next to "Activities") but after a few seconds the process seems to die and nothing happens. Trying to launch GitKraken from the console fails too with the following two messages:

/snap/gitkraken/58/bin/desktop-launch: line 23: $HOME/.config/user-dirs.dirs: Permission denied
ln: failed to create symbolic link '$HOME/snap/gitkraken/58/.config/gtk-2.0/gtkfilechooser.ini': File exists

Unfortunately, my Linux skills are too limited to solve this. The only thing I've tried is chmod 777 $HOME/.config/user-dirs.dirs because of the Permossion denied but that did not help.

EDIT: as terdon suggested in his comment I've made ls -ld ~/.config/user-dirs.dirs and this is its output:

-rwxrwxrwx 1 myusername myusername 633 Mai 6 10:30 /home/mayusername/.config/user-dirs.dirs

Then, I made the mv ~/snap/gitkraken/58/.config/gtk-2.0/gtkfilechooser.ini gtkfilechooser.ini.bak command and tried to start GitKraken afterwards. I did not start showing again:

/snap/gitkraken/58/bin/desktop-launch: line 23: /home/myusername/.config/user-dirs.dirs: Permission denied

The ln: failed to create symbolic link ... error from my initial post did not appear. Exe cuting ll in the directory ~/snap/gitkraken/58/.config/gtk-2.0 gives me the following output:

drwxrwxr-x 2 myusername myusername 4096 Jun  3 16:44 ./
drwxrwxr-x 8 myusername myusername 4096 Mai 21 12:28 ../
lrwxrwxrwx 1 myusername myusername   47 Jun  3 15:45 gtkfilechooser.ini -> /home/myusername/.config/gtk-2.0/gtkfilechooser.ini
-rw-r--r-- 1 myusername myusername  198 Jun  3 16:44 gtkfilechooser.ini.bak

gtkfilechooser.ini -> /home/myusername/.config/gtk-2.0/gtkfilechooser.ini is red since the file does not exist anymore. Executing the chmod command afterwards did not change anything. GitKraken does not start and outputs the same errors.

1
  • 2
    Please edit your question and post the output of ls -ld ~/.config/user-dirs.dirs. Also, try running mv ~/snap/gitkraken/58/.config/gtk-2.0/gtkfilechooser.ini gtkfilechooser.ini.bak and launching again. Finally, tell us if running the chmod command made any difference.
    – terdon
    Jun 3, 2018 at 12:15

2 Answers 2

40

SOLVED: Had to install libgnome-keyring: sudo apt install libgnome-keyring0

The UI now comes up and works for me. Still get the following warnings, but it's working:

Gtk-Message: 11:19:31.343: Failed to load module "overlay-scrollbar"
Gtk-Message: 11:19:31.349: Failed to load module "canberra-gtk-module"
Node started time: 1528391971495
state:  update-not-available
EVENT: Main process loaded at 441 ms
state:  checking-for-update
state:  update-not-available
state:  checking-for-update
state:  update-not-available
EVENT: Starting initial render of foreground window at 5331 ms
EVENT: Startup triggers started at 5446 ms
1
  • 2
    Yeap. sudo apt install libgnome-keyring0 worked for me too in Linux Mint 19.
    – f0nzie
    Sep 23, 2018 at 16:13
1

In Ubuntu 19.10 I cannot run it after snap installation, so I removed Gitkraken from snap and then installed it after downloading from this site

https://www.gitkraken.com/download/linux-deb

1
  • Using the RPM instead of the Snap package worked for me on RHEL. The Snap application was always stuck on the splash screen. See support.gitkraken.com/how-to-install/… for installation instructions.
    – mic
    Nov 6, 2020 at 23:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .