-1

Following these guides (https://github.com/ToadKing/wii-u-gc-adapter/blob/master/README.md and https://dolphin-emu.org/docs/guides/how-use-official-gc-controller-adapter-wii-u/#Linux) - I've tried these steps:

  1. sudo su; apt update && apt upgrade -y && apt dist-upgrade -y && apt install jstest-gtk -y
  2. echo 'SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ATTRS{idVendor}=="057e", ATTRS{idProduct}=="0337", MODE="0666"' > /etc/udev/rules.d/51-gcadapter.rules
  3. exit
  4. cd ~/Downloads
  5. sudo apt install libusb-dev libudev-dev -y
  6. sudo modprobe uinput
  7. git clone https://github.com/ToadKing/wii-u-gc-adapter
  8. cd ~/Downloads/wii-u-gc-adapter
  9. make
  10. sudo ./wii-u-gc-adapter
  11. jstest-gtk

When I do lsusb, I get Bus 001 Device 011: ID 057e:0337 Nintendo Co., Ltd but nothing shows up in jstest-gtk.

I unplugged/replugged the adapter and nothing.

I'm totally stumped. Any advice? See any obvious mistakes I'm making?

0

What worked for me is returning the off brand hardware and buying the official adapter made by Nintendo. The off brand YTEAM adapter doesn't seem to work with Linux.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.