1

My cellphone connects just fine to the 5Ghz network, so I know it is up and functioning properly. My Dell Inspiron though, running elementary OS Loki which is based on Ubuntu 16.04, refuses to do so and instead connect to the 2.4GHz network which has a much lower signal strength.

Here's the iwlist output, which confirms it actually sees the 5Ghz channels:

$ iwlist wlp18s0 freq
wlp18s0   32 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 36 : 5.18 GHz
          Channel 38 : 5.19 GHz
          Channel 40 : 5.2 GHz
          Channel 42 : 5.21 GHz
          Channel 44 : 5.22 GHz
          Channel 46 : 5.23 GHz
          Channel 48 : 5.24 GHz
          Channel 52 : 5.26 GHz
          Channel 56 : 5.28 GHz
          Channel 60 : 5.3 GHz
          Channel 64 : 5.32 GHz
          Channel 100 : 5.5 GHz
          Channel 104 : 5.52 GHz
          Channel 108 : 5.54 GHz
          Channel 112 : 5.56 GHz
          Channel 116 : 5.58 GHz
          Channel 120 : 5.6 GHz
          Channel 124 : 5.62 GHz
          Channel 128 : 5.64 GHz
          Channel 132 : 5.66 GHz
          Channel 136 : 5.68 GHz
          Current Frequency:2.437 GHz (Channel 6)

I've tried setting power management to OFF as explained here, I've set the domain to US as explained here (I'm in the US right now). I've tried forcing the network manager to use the 5GHz channels, but it just won't work.

These are my card specs ($ sudo lshw -C network):

BCM4313 802.11bgn Wireless Network Adapter (Broadcom Corporation)

Any ideas will be greatly appreciated.

5

The BCM4313 WiFi chipset is a single frequency 2.4GHz chipset. It is capable of going to a theoretical speed of around 150Mbps.

You might also suspect by the lsusb output, in the 802.11bgn string, it does not support 5GHz (802.11b, 802.11g are not in the 5GHz band*, and in 802.11n the 5GHz band support is optional). So there is already here a hint iwlist is showing too many channels. (it is showing 802.11ac channels)

To check it out for sure, we should have a look at the product page from Broadcom itself Broadcom - BCM4313

Single-chip, single-band, IEEE 802.11n MAC/PHY/Radio system-on-a-chip (SoC).

MAC (Media Access Control), baseband and radio for 2.4 GHz IEEE 802.11n applications

So obviously, your BCM4313 won't ever connect to any 5GHz channel.

iwlist either is showing all the frequencies the command accepts, or most probably, lying.

Maybe the driver/firmware is common with later models. Maybe it is bug. Nevertheless, the hardware won´t support 5GHz frequencies.

The chipset is also obsolete as we speak, and (in)famous for being problematic. I also have several reasons to suspect it is a 802.11n DRAFT card (e.g. before the protocol was totally defined as it is today).

I would also warn you before you trying to substitute the actual WiFi card, that Dell engages in device whitelisting, and you can only buy another WiFi card "compatible" with your notebook model.

See also an aliexpress listing of your present card. Notice the "only compatible with Dell" wording and again:

Wi-Fi Supported Frequency:2.4G

I would search if your particular Inspiron model/firmware supports a 5GHz "Dell compatible" card, and might try to switch it. As there is whitelisting involved, upgrading to a later version of the BIOS/firmware might support more Wi-Fi chipsets.

Nonetheless, typically new 5GHz cards might need a different type of antenna(s) and an extra antenna (they are inside the machine body).

So your best bet at the end of the day might be getting a 5GHz USB stick. Select it wisely before buying.

See related Wi-Fi problems using ASUS USB-N13 adapter for comments and suggestions about WiFi technology.

  • 1
    @Gabriel What year is your Dell Inspiron from? That brand name is used since the 90s. – Rui F Ribeiro Jun 3 '18 at 3:28
  • 1
    Thank you very much for your detailed answer Rui! Indeed I suspected that having 5Ghz channels listed by iwlist might be a mistake, because if I load a new Ubuntu 18.04 from a USB and try that same command, only the 2Ghz channels are shown. This is an old laptop (Inspiron N5010, ~8 years old) so I don't intend to upgrade the chipset, I have to upgrade the entire laptop. Thank you again! – Gabriel Jun 4 '18 at 0:26
  • 1
    As it is an old laptop, you may always buy a 10-15 USD USB pen in aliexpress and use it outside or hack the hw for it to be inside. Abrazos – Rui F Ribeiro Jun 4 '18 at 0:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.