2

I am a victim of this bug: Thunderbird not start with .icedove folder - Debian 9 #1686


Description:

When starting Thunderbird it automatically creates a directory named .icedove. If this directory is not getting deleted manually after each session, Thunderbird will complain about the existence of .icedove at every startup.

I am using neither Firejail nor other Add-ons. How can I prevent Thunderbird from automatically generating the directory .icedove during Thunderbird's start process?

It seems like the recommended solution on GitHub is only valid in case of usage of Firejail. However, without Firejail installed the mentioned file /etc/thunderbird.profile does not even exist on my system.

Do you have any ideas on how to solve this issue?

3 Answers 3

3

Goto Edit > Preferences > Advanced > General > Config Editor, and search for entries containing the string ".icedove". Replace this string for each single entry by .thunderbird. Terminate your Thunderbird session, and for a last time remove the .icedove directory. Now you should be able to restart Thunderbird without problems.

1
  • You are right! Thank you very much for your hint!
    – Dave
    Jun 10, 2018 at 12:26
2

Debian crew forked and renamed the Thunderbird as Icedove for couple of years ago. The Thunderbird, under name Thunderbird is back on Debian, but I guess there is still some old code left, from the time Thunderbird was renamed Icedove.

2
  • Please unaccept this answer, which is wrong. The migration problems can be fully explained by missing conversion of parameter settings (see my answer). Thence no reason to suspect a buggy reference to .icedove in the code.
    – Joachim W
    Jun 8, 2018 at 8:01
  • I don't think it's wrong per se, code in the TB codebase proper, just that something is keeping the .icedove directory around such that TB leaves the migration as a symlink from .thunderbird to .icedove and calls it finished. If there's some last part of the migration process that I'm missing, I haven't been able to find it for years. In fact, as far as I can tell, your answer is the only place a real fix is described, and it appears even Debian themselves don't know: wiki.debian.org/Thunderbird#Adoption_of_User_Profiles
    – Eric
    Dec 19, 2020 at 20:42
0

In the account settings, for each mail account you have look at the server settings, under the heading "Message Storage" you will see a field named Local Directory: /home/user/.icedove/xxxxxxxx.default/ImapMail/imaps.isp.ch make the necessary change from ".icedove" to ".thunderbird" as modelled below /home/user/.thunderbird/mlnwvjfx.default/ImapMail/imaps.isp.ch (Adapt to your own settings)

Do this for all your accounts so there is no automatic recreation of the .icedove directory.

If you store your messages in a local folder, click under Account Settings on the Local Folders, Message Storage, Local Directory setting and again make the needed change as described above.

After each edit you will be required to restart Thunderbird. Use the work off-line setting to halt synchronizing to the old .icedove folder.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .