I have read the answer to a post, it suggest to use:

systemctl set-default multi-user.target

to log in command line mode. It works fine, except before login, it seems CentOS has boot into the graphical mode which make the start up process quite slow. See the following picture: enter image description here

I have minimal installed CentOS before, it boot much faster compare to my situation now. So what's the reason for this, and how to get rid of the pre-boot gui?


To get rid of the pre-boot GUI you have to remove the rhgb option in the grub options. If you also want the kernel messages during boot, you also have to remove the quite option of the kernel append line.

To do so, edit the file /etc/default/grub with a text editor of your choice and adopt the GRUB_CMDLINE_LINUX.

If you just want to remove the pre-boot GUI it would look as follows.


If you also want the kernel messages during boot, just set it as f


You also might want to preserve the default entry in the file and to do so you just comment that line with #.

After you have edited the file you have to generate the grub configuration as follows.

grub2-mkconfig -o /etc/grub2.cfg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.