0

I set up my old PC with debian, which worked fine after running the installer from windows. But seems like I messed up some files while trying to get the touchpad-tap to work( followed this "guide" https://unix.stackexchange.com/a/337218/293324).

After that I rebooted my System, and just got a terminal view, no GUI. The command "startx" ends in a fatal error. I think I tried almost everything right now, even to delete the directory "xorg.conf.d" I created beforehands. Also stuff like apt-get purge gdm and apt-get install gdm (with gdm3, gnome, gnome-service and gnome-desktop) isn't working because the system doesnt find the packages.

I think my last option to get a GUI back is to reinstall the system, but after many hours with google I didn't find a way to reinstall it without an external boot device.

Extra Information: My cd/dvd player is broken and my pc also doesn't like external bootable drives(usb)

Do you have some ideas how to get the GUI back, or how to reinstall debian from the terminal?

Edit: The log file( Xorg.0.log) some errors may occur through hand passing.

 [  324.712]
 X.Org X Server 1.19.2
 Release Date: 2017-03-02
 [324.713] X Protocol Version 11, Revision 0
 [324.714] Build Operating System: Linux 4.9.0-4-amd64 i684 Debian
 [324.714] Current Operating System: Linux Nat 4.9.0-6-686-pae #1 SMP Debian 4.9.82-1*deb9u3 (2018-03-02) i686
 [324.714] Kernel Command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-6-686-pae root= ...
 [324.714]Build Date: 16 October 2017 08:12:56AM
 [324.715]xorg-server 2:1.19.Z-1+deb9u2 (https://www.debian.org/support)
 [324.715] Curreng version of pixman 0.34.0
 [324.715]  Before reporting probblems...
 [324.715]Markers: (--) probed, (**) from config file, (==) default settings, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
 [324.716](==) Log file: "/var/log/Xorg.0.log", Time: Thu May 31 08:04:25 2018
 [324.717] (==) Using confog directory: "/etc/X11/xorg.conf.d"
 [324.717]n(==) Using system config directory "/usr/share/X11/xorg.conf.d"
 [324.717]Parse error on line 9 of section InputClass in fule /usr/share/X11/xorg.conf.d/70-wacom.conf "Section" is not a valid keyword in this section.
 [324.718] (EE) Problem parsing the config file
 [324.718] (EE) Error parsing the config file
 [324.718] (EE)
 Fatal server error:
 [324.718] (EE) no screens found(EE)
 "...log file and support notice"

Edit2: Interesting that the error occurs from a file in the directory i thought I deleted. would pass the file, but it's a little too long and doesn't look like there's a "Section" declared without an "EndSection" or inside another Section. But from Line 9-15 it looks like:

Section "InputClass"
   Identifier "Wacom USB tablet class"
   MatchUSBID "056a:*"
   MatchDevicePath "/dev/input/event*"
   MatchIsTablet "true"
   Driver "wacom"
EndSection
  • Hello and welcome to Stack Exchange. Please allow me to give you a piece of advice: you have to work on your troubleshooting skills. It can be very frustrating to face something we don't fully understand, we all get that, but if you're interested in learning something out of this, this mentality of rebooting/reinstalling whenever something goes wrong is harmful and will slow you down in the long run. Instead of panicking and going on removing directories and programs, you should take some time to learn about Xorg and what it means to put a file in the "xorg.conf.d" directory, for example. – Arthur Hess May 31 '18 at 4:09
  • Hey Arthur, thx for your comment. You may be right about that. Normally I get a problem, and have some kind of an idea, but now I'm facing a problem, where I really got no Idea how to deal with. An external stressor maybe that I have to claim warranty on my "new" Laptop, in the next few days, before my warranty expires(400$ on unexpected gravity influence are more affordable than a new one), and I need a laptop for university in the meantime. But, I really hope to learn something out of this problem since I'm also new to the unix/linux world. Hope you excuse my little panick attack – Nathanael Nussbaumer May 31 '18 at 4:31
  • Oh and I just installed the OS and did nothing else than trying to get the touchpad-tap(left mouse button at "old" laptop is also broken^^) to work so nothing, but tme, for me to lose – Nathanael Nussbaumer May 31 '18 at 5:19
  • The first step of troubleshooting on Linux machines is to check the log files. Can you paste the lines containing errors from the X.org log file? – Lawrence May 31 '18 at 5:49
  • Are you dual booting Windows in a machine with two graphic cards? – Rui F Ribeiro May 31 '18 at 6:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.