3

I am trying to install postgis2_94 on CentOS 7.5 with the following command (having already installed postgresql94 ):

yum install postgresql94-server postgresql94-devel postgis2_94 postgis2_94-docs postgis2_94-utils pgrouting

But, I get the following error:

Transaction check error: file /usr/pgsql-9.4/bin/shp2pgsql-gui conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64 file /usr/pgsql-9.4/lib/liblwgeom.so conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64 file /usr/pgsql-9.4/share/extension/address_standardizer.control conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64 file /usr/pgsql-9.4/share/extension/address_standardizer.sql conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64 file /usr/pgsql-9.4/share/extension/address_standardizer_data_us.control conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64 file /usr/pgsql-9.4/share/extension/address_standardizer_data_us.sql conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64 file /usr/pgsql-9.4/share/extension/postgis.control conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64 file /usr/pgsql-9.4/share/extension/postgis_sfcgal.control conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64 file /usr/pgsql-9.4/share/extension/postgis_tiger_geocoder.control conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64 file /usr/pgsql-9.4/share/extension/postgis_tiger_geocoder.sql conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64 file /usr/pgsql-9.4/share/extension/postgis_topology.control conflicts between attempted installs of postgis24_94-2.4.4-2.rhel7.x86_64 and postgis22_94-2.2.7-1.rhel7.x86_64
Error Summary
-------------

How can I solve that?

  • Did you ever find an answer? I have a similar issue with postgis2_95. – JosephK Jun 4 at 13:04
  • I don't really remember how I fixed this :(, I might be able to find something in my docs though. – codezombie Jun 8 at 10:19
  • It's ok. I solved this by moving to Ubuntu - all installed w/o conflicts, etc. Too many headaches with CentOS all the time - cannot afford any more wasted days with it. – JosephK 18 hours ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.