0

There are many questions like this one, but mine seems to be unique. I have a HiDPI display on a System76 laptop, and running uname -a gives

Linux Ulfhednar 4.13.0-43-generic #48~16.04.1-Ubuntu SMP Thu May 17 12:56:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I recently installed winswitch and xpra to run a program called run_scaled, which is a recommended fix to scaling problems for some software when using HiDPI display monitors (can't find the StackOverflow question anymore). After getting run_scaled to work properly, the next time I booted up my laptop I could not use my mouse or keyboard at the login screen and, after about 10 seconds, the cursor inside the "Password" box stopped flashing, so the system presumably froze.

This drove me down an agonizing many-day long journey to find a fix to the problem while running off a LiveUSB trial of Ubuntu 16.04. In desperation I reinstalled lightdm, and reinstalled xserver-xorg-input-all at the recommendation of StackOverflow questions. Neither of these changed anything. I also tried making changes to my grub file to get a terminal at boot, but this eventually resulted in a black screen with a blinking cursor on boot, which would only go away when I pressed the power button.

I think the change that I made to my grub file that caused the black screen with blinking cursor was the one found in this StackOverflow quesion,

GRUB_CMDLINE_LINUX_DEFAULT="text"

but I forgot to uncomment GRUB_TERMINAL=console. I tried reverting my grub file to its original state, as I had a backup file, but that still did not change anything. Then, I only uncommented GRUB_TERMINAL=console, updated the grub, and rebooted.

This time, I was greeted with a black screen and a small white error message in the center of my screen, saying something bad had happened with video mode (I can't remember exactly what it said). I waited for a bit, pressed enter, and then the computer booted to the login screen, except this time I could use my mouse and keyboard! I logged in and immediately made this post, because I know my problem is not yet solved.

I noticed that I booted into my 4.13.0 kernel instead of 4.10.0, which is not what I expected. When I booted into any kernel when I was still having problems, it didn't change anything and the login screen was still frozen.

If you have any ideas on how to fix this issue I'm having, please let me know! I'm willing to provide as much information as possible to help find a way to undo whatever it was that I did. Thank you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.