0

Introduction

I've installed void linux on an x200 thinkpad with a minimimal install using an ethernet cable as i couldn't connect using wifi.

The problem

ip a

i have no ip address for my wifi device. I assume this is because i don't have the wifi driver installed:

lspci

03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection

I've queried the void linux musl respository and couldn't find a package for 5100 AGN wifi driver. How do i install the driver to get my wifi card to work and thus connect to the internet?

  • It must be called iwlwifi in Debian according to my 1 minute Google search, it might be a clue, it might be wrong. Beware it might need firmware. I suspect you are better off with Ubuntu. – Rui F Ribeiro May 30 '18 at 3:12
0

Install the linux firmware packages:

# xbps-install -Suv linux-firmware linux-firmware-network

You will likely have to do this by chroot'ing into the root filesystem, since you do not have networking when booting into it.

0

The Intel 5100AGN should use the iwlwifi driver so should be installed including the firmware with just the basic minimal void live USB dist at least with the glibc build. I am not sure about the musl. Everything worked for my basic install with glibc without using a network connection. Then I had to configure the wifi and could finally connect.

I think you might have a configuration problem. You can check the dmesg for any problems. You can try "iw phy0 info" and see what that says.

I always add a 70-persistent-net.rules to /etc/udev/rules.d/ so my wifi gets named wlan0 every time. That needs the MAC of the wireless adapter. Then I configure the wpa_supplicant-wlan0.conf with wpa_passphrase. Then set up the /etc/sv/dhcpcd-wlan0 and start by linking in /var/service. This is all explained in the void wiki for networking.

If you are new to void then the desktop installations have the networking setup from the desktop with a graphical application and might be an easier way to begin than the basic minimal distribution.

EDIT: Maybe check the BIOS to see if the wireless card is enabled?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.