I'm running Fedora 28 on my Acer Laptop for more than a week now. Since I usually use it at university, I decided to use the update server provided by the university, https://ftp.halifax.rwth-aachen.de/.

At first this worked just fine but shortly after I changed the mirror, I found out that some packages that are listed in the fedora package list at https://apps.fedoraproject.org/packages/ were not available on my system. The error message is:

$ sudo dnf install docker
Last metadata expiration check: 0:00:44 ago on Tue 29 May 2018 17:56:58 CEST.
No match for argument: docker
Error: Unable to find a match.

As soon as I revert my changes, I can install docker and apcalc without any issues.

Here is what I changed in /etc/yum.repos.d/fedora.repo and fedora-updates.repo:

# comment out the following line:
# add this line instead:

Does anyone know how to fix this issue? If the issue cannot be fixed on my laptop, how can I debug/fix the issue on the server with the help of the server maintainer (who does not have a clue how Fedora works)?

  • You already told us how to fix the issue in your question. It seems you need to select a repository that isn't missing the packages you want to install.
    – DopeGhoti
    Commented May 29, 2018 at 19:29
  • @DopeGhoti I have contacted the administrator of the halifax mirror already and he said that he does not have any clue why the packages are missing. If this is a problem with the server, can you still tell me how I can debug/fix the problem?
    – msrd0
    Commented May 29, 2018 at 19:30
  • @msrd0 You can't fix the server, but you could pick another mirror to see if it's a problem with the particular mirror that you're ordinarily using.
    – Kusalananda
    Commented May 29, 2018 at 19:34
  • 1
    The apcalc program in debian is just called calc in Fedora. Try sudo dnf install calc. Since you say things work in the default configuration, maybe that's what you meant?
    – mattdm
    Commented May 29, 2018 at 19:51
  • @mattdm I've used ArchLinux before where the package is called calc. Running calc on Fedora (with official repo list) suggests me to install apcalc, and running sudo dnf install apcalc worked just fine (I can't tell you why, it's obviously called calc in Fedora too).
    – msrd0
    Commented May 29, 2018 at 19:54

2 Answers 2


This is clearly a problem with your university's repository being an incomplete mirror. Compare for example the packages (starting with the letter 'd' so as to seek your example case of docker) visible here at your university, as opposed to here at an official Fedora mirror (as found here). If you want to use your university's repository, you will need to convince its maintainer of the incompleteness of the mirror.

  • looks like my university is updating its mirror from the mirror of the tu chemnitz, which is just as incomplete as ours
    – msrd0
    Commented May 29, 2018 at 19:42
  • 2
    In your example, you're comparing two different repositories. One is for updates repository, the other is for release repository. That's why one has packages that the other doesn't have.
    – Nuno Dio
    Commented May 29, 2018 at 20:07

In my understanding your university mirror for Updates repository is correct.

Eventually, you are missing the "release repository". Can you please confirm if you have a "release repository" installed?

You should look at /etc/yum.repos.d for a configuration that has the base URL:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .